×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

TP Error: Version mismatch for shared memory

TP Error: Version mismatch for shared memory

TP Error: Version mismatch for shared memory

(OP)
I'm doing some work on an old machine that is running HPUX 10.20, Oracle 733, MIMS 4.1 and TP 2o (told you it was old :))

Was trying to copy to a testing machine - and couldn't get the 2o to compile.  Had a tar of a 1r TP lying about so I thought to myself "Self, let's try to install that".

Got it installed and compiled.

Updated /etc/mincom_tp.tbl to point to the new $MINCOM_TP directory.

Then, when I try to run *anything* - be it msstrtup, tp_stat, tp_info, I get:

tp_info  041104 004218 [MINCOM TP Version 3.008/2O]
...................... Acode:  102 Version mismatch for shared memory


Somehow it's still thinking that it's running the 2o instead of the 1r and it's causing me no end of pain.

I removed the 2o directory so it's not even there any more.  Don't know where it's picking up to 2o version from.

Just for background, I did do a complete remake:

make CLEAN
tp_config
logout/login
tp_mkfl
make

Any closet TP experts out there?  I could really use a pointer on this one.  Only thing I can think of is that there's still a process running in memory (can't see anything when I do a "ps -ef | grep mimsp" but there may be some semaphore left over somewhere or something.

I know I'm missing something, probably something glaringly obvious, I just can't pinpoint it.

Anyone able to give me a pointer?

Thanks
Steve

stephen.wales@riotinto.com

RE: TP Error: Version mismatch for shared memory

Two things you should check:

1) The mmap files have been removed.
cd $MINENV_RUN
rm *mmap*

2) Make sure the there is no HPUX10.sh file in the $MINENV_RUN/login directory.

RE: TP Error: Version mismatch for shared memory

(OP)
Yeah, I had the rm *mmap* epiphany on Saturday evening before I'd seen this post.  That was the missing link in my puzzle.

Thanks

stephen.wales@riotinto.com

RE: TP Error: Version mismatch for shared memory

Another thing you might need to do is run the msgenenv script to recreate .env file.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close