×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

credentials supplied conflict

credentials supplied conflict

credentials supplied conflict

(OP)
I'm not quite sure where I should have posted this...

I have about 20 people so far that are getting the following message:

>>
An error occurred while reconnecting X: to "\\tree\o\volume"

NetWare Services: The credentials supplied conflict with an existing set of credentials.

This connection has not been restored.
<<

This happens on Win 2000 systems with Novell Client 4.81. We have two trees. The primary tree works fine, but when their mapped drives try to remap to the old tree, the error message pops up. This only happens after a reboot and never after a logout/login.

I have conflicting reportss as to what is fixing it. One is that to unregister and reregister with wsreg the system in the new tree works and the other is that deleting the old tree and and context from the client properties. I honestly don't think either of these is really "working". It seems as though waiting long enough allows the client to discover the old tree.

If the user just browses out to the old tree after receiving the error message, the authenication process occurs normally.

This one is a real pain for me because as far as I know nothing has changed much in either tree or on the systems to cause these systems to behave in this way.

If anyone has any clue as to the direction I should be looking, I would greatly appreciate it.

RE: credentials supplied conflict

You'll get that message if you have a drive mapped to a resource as one user, and you try to map another drive using a different user.  I don't believe it has anything to do with your WSREG..

You'd be better off merging your trees, if that is an option, so you only have one credential to deal with per user.

Marvin Huffaker MCNE, CNE
Marvin Huffaker Consulting
http://www.redjuju.com

RE: credentials supplied conflict

(OP)
We have found the issue. A registry entry is added to the client system key "HKEY_LOCAL_MACHINE\SOFWARE\Novell\NetWareWorkstation\ServerCache" for each authenication with a server name. The entry it is writing for our old tree is actually a random server in our new tree, therefore, it will never find the server.

I tried to manually change the value from "oldserver" to "newserver" but it somehow got set back to a wrong server/right tree scenario.

I also tried to set the registry key...
 "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetWareWorkstation\Parameters

[Dword] Value:
ServerCacheTimeout= 0x00000015 (21)"

...to 0, but I'm not sure this will work either.

Does anyone know what writes this entry or how I may be able to correct this?

Name Cache TID:
http://support.novell.com/cgi-bin/search/searchtid...

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close