×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Installation Error

Installation Error

Installation Error

(OP)
Hi I'm trying to install Verita's Backup Exec 9.1 on Windows 2003 Standard Edition. Half way through the install, it halts on installing the SQL componants. An error message appears saying

Fatal SQLUNIRL.DLL Initialization Error
'File: ..src\procaddr.c\ line: 422
 COMCTL32.DLL Could not be loaded, NT Error 998'

This is the last part of the log file:

roperty(S): DATABASE = C:\WINDOWS\Installer\9f652.msi
Property(S): OriginalDatabase = Z:\WINNT\INSTALL\MSDE\Setup\SqlRun01.msi
Property(S): UILevel = 2
Property(S): ACTION = INSTALL
Property(S): AgentServiceName = SQLAgent$BKUPEXEC
Property(S): InstanceRegKey = Microsoft SQL Server\BKUPEXEC
Property(S): InstanceSubDir = MSSQL$BKUPEXEC
Property(S): SqlPerfMonRegKey = SQLCTR$BKUPEXEC
Property(S): SQLServiceName = MSSQL$BKUPEXEC
Property(S): SqlStates = 0
Property(S): ROOTDRIVE = F:\
Property(S): CostingComplete = 1
Property(S): OutOfDiskSpace = 0
Property(S): OutOfNoRbDiskSpace = 0
Property(S): PrimaryVolumeSpaceAvailable = 0
Property(S): PrimaryVolumeSpaceRequired = 0
Property(S): PrimaryVolumeSpaceRemaining = 0
Property(S): SqlFeature = SqlRun
Property(S): SOURCEDIR = Z:\WINNT\INSTALL\MSDE\Setup\
Property(S): SourcedirProduct = {E09B48B5-E141-427A-AB0C-D3605127224A}
Property(S): ProductToBeRegistered = 1
=== Logging stopped: 3/10/2004  17:29:20 ===
MSI (s) (D8:EC): Note: 1: 1708
MSI (s) (D8:EC): Product: Microsoft SQL Server Desktop Engine -- Installation operation failed.

MSI (s) (D8:EC): Cleaning up uninstalled install packages, if any exist
MSI (s) (D8:EC): MainEngineThread is returning 1603
MSI (s) (D8:40): Destroying RemoteAPI object.
MSI (s) (D8:A0): Custom Action Manager thread ending.
MSI (c) (48:30): Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (48:30): MainEngineThread is returning 1603
=== Verbose logging stopped: 3/10/2004  17:29:20 ===

Is it something to do with the version of MSDE i'm installing?

Thanks

Rich

RE: Installation Error

RE: Installation Error

Hi,

I was just wondering if you managed to get a fix for this. I'm having the same problem and I've tried everything but still no luck.

RE: Installation Error

I am currently having the same problem and I am in contact with Veritas.  They have had me delete numerous reg keys and other files, but the MSDE instance just doesn't want to install.  I will let you know of any magical fix they have if they can actually fix it.

RE: Installation Error

Any news on this issue? I'm experiencing similar problems on installing MSDErelA. It just won't install ....

cheers, BS

RE: Installation Error

Well basically its not a Veritas Issue. Try installing MSDE manually from microsoft website and you will get the same error. There shuld be a c:\systemroot\msde_bkupexec.log file. This is the mSDE install log file.  If you search for "return value 3" in the log the error is right above this line. There should be several return value 3. Make sure the MDAC is up to date and all the SQL registy keys are cleared. If it SBS then I would suggest Veritas or Microsoft Guidence in removing the keys.

richyd - I would look further up in the install log for the error
 
 

RE: Installation Error

thnx for the tip! I found the following error in the logfile:
"
Starting custom action InstallSQLAgentSecurity
InstallSQLAgentSecurity failed (JAMAICA,LocalSystem,87).
Action ended 22:46:30: InstallFinalize. Return value 3.
"

there's a lot of info on this error: http://www.google.nl/search?biw=1003&hl=nl&q=InstallSQLAgentSecurity+failed&meta=

First I'll try the "remove terminal server"-option. I'll let you know if it worked.
Cheers, BS

RE: Installation Error

p.s. I figured it was not a Veritas but a MSDE-issue, but this was the only relevant thread/discussion I could discover ...
BS

RE: Installation Error

Your installing on a DC - change the PDC emulator role to the local server and the install will complete. The change the role back

RE: Installation Error

We'll try it tomorrow (it is a DC indeed, with de PDC emulator role on another server). Meanwhile, I've noticed that the registry is polluted with SQL-entries (trial and error / failed installs). Is for example 'Registry Mechanic' an option to clean these entries?
thnx! BS (NL)

RE: Installation Error

Johojoho! It works! Installation succesfull after (temporary) transfer of PDC-role. Furthermore I've installed from a consolesession and not a TS-session, but I'm not sure if that's a factor since the failed installations were also from a consolesession. One last item; the MSSQLServerADHelper-service failes to start with error: -1073741724 and the eventlog says: '0' is an invalid number of start up parameters. This service takes two start up parameters.
Any idea?

thnx again, BS (NL)

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close