×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Deploying WARs to Silverstream

Deploying WARs to Silverstream

Deploying WARs to Silverstream

(OP)
Is anyone out there having any success deploying WAR files to SS using the 3.7 DeployWar command?

I have a simple WAR containing a JSP, Servlet etc. that deploys fine in TomCat. I am getting an odd Error 500 with SS during upload:
---
Extracting the WAR file...
Done.
Reading deployment descriptor...
Done.
Setting up compile environment...
ignoreErrors for JSP compile: false
classpath for JSP compile:
<snip>
Done.
Compiling any JSPs...
  hello.jsp
Done.
Uploading files for deployment to server...
  http://localhost/MyApp/SilverStream/Classes/Jars/myapp-contents.jar
  http://localhost/MyApp/SilverStream/Classes/Jars/myapp-webinf.jar
  http://localhost/MyApp/SilverStream/Classes/Jars/myapp-classes.jar
Uploading jars in WEB-INF/lib...
Uploading deployed object 'myapp.war' to server...
com.sssw.rt.util.AgoHTTPStatusException: Failure code 500 on http://localhost/MyApp/SilverStream/Objectstore/Jars/myapp.war.
---

Has anyone seen anything similar?



 

RE: Deploying WARs to Silverstream

well try it out on the Xtend Workbench from silverstream.
I was also facing the similar problems but after deploying from workbench I could develop and deploy the JSPs and Servlets on the Server.

It is available on the Silverstream web site.

RE: Deploying WARs to Silverstream

I had something like that before.  It took me ages to work out but it finally was something really simple.  What I did is I put my JSP in a folder which was exactly the same name as the SilverStream DB, which I found to be causing that Http Status Exception.  Once I changed the folder name it worked fine.
Rob.

RE: Deploying WARs to Silverstream

I can't reach jsp in subcatalogs...work on my local installation, but not on a Unix HP insta.

tga

RE: Deploying WARs to Silverstream

(OP)
I have now (and with the help Silverstream european support) cracked this one. I have no idea what caused the original problem. I made a few changes and it disappeared.

WARs now deploy effortlessly to Silverstream as part of my Ant (http://jakarta.apache.org/ant) build.

RE: Deploying WARs to Silverstream

Write a server object and catch the httperror event exception .
This will give information as to why this happens .
It is clearly a mistake in the code that you are trying to deploy

There is no other way to find the error .

RE: Deploying WARs to Silverstream

same error while deploying from Extend onto SS 3.7. But only on a particular SS server. Deplying onto a diff 3.7 server works just fine.....

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close