×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

CANNOT MAKE SET ALL=PASS WORK

CANNOT MAKE SET ALL=PASS WORK

CANNOT MAKE SET ALL=PASS WORK

(OP)
Hi
I've reac a couple of threads about left joins, and was hoping they would help in my current situation.

I thought that -SET ALL=PASS; would work to allow me to return unmatched records on a master table while using a where statement to govern the returns on the guest table.  

unfortunately it does not seem to be working as described, and is behaving as an inner join.

I tried setting 'SQL EDA OPTIMIZATION ON' With no luck.

I'm working in wf 4.3 with eda connecting to informix database...

any help gettting the SET ALL= PASS to work as a left join would be much appreciated
M

RE: CANNOT MAKE SET ALL=PASS WORK

Are you using -SET ALL=PASS or SET ALL=PASS (without the leading hyphen?

RE: CANNOT MAKE SET ALL=PASS WORK

(OP)
Actually, I've tried both ways, as well as with a ';' to no avail...

What does the leading hyphen do for me anyway, I've noticed while the conventions here (my place of work) seem to be to use it, on the forums, few people include it in their posts

thanks much

RE: CANNOT MAKE SET ALL=PASS WORK

There are certain commands (Dialog Manager) that need to have the hypnen.  Other SET commands (non-Dialog Manager) do not require them.

RE: CANNOT MAKE SET ALL=PASS WORK

Have you tried extracting data from both files and using MATCH FILE logic with the appropriate OLD-NOT-NEW, OLD-AND-NEW, etc.

RE: CANNOT MAKE SET ALL=PASS WORK

(OP)
yes, actually I have, and the problem is performance, one of the tables involved is pretty big with little way to narrow it down.

I'm looking to use the set all=pass to leverage the performance of a join.  the set all=on setting works, and the problem is that I am parameterizing a field of the guest table, which is why I am going with the set all = pass

 
Is there an optimization setting that I can use to make this work? or do I mis understand the purpose of set all = pass


RE: CANNOT MAKE SET ALL=PASS WORK

If you only want unmatched records where rows in table A are NOT in table B, you should be doing a SET ALL=OFF. SET ALL=PASS will do an outer join.  Do not use -SET &ALL.  This is a totally different command that is used for debugging.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close