Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


NFS mount timeout

NFS mount timeout

NFS mount timeout

Hi all,

i try to mount on  may AIX 4.3.3 box a filesystem exported by a linux server with RedHat 9

The network seem to be ok, i can log on the two servers from each other using ssh, telnet. Ping is ok beetween the servers.

- My linux server also export other filesystems to another server and works fine.

- /etc/exports is ok and i reexpoted all the filesystems using exportfs -rav

- NFSd and portmaper are stared on the two machines.

When i try to mount the filesystem on my AIX box, smity gives me the folowing message:

mount: server lnxsrv not responding
: RPC: Port mapper failure - RPC: Timed out
mount: backgrounding

Any idea ??

RE: NFS mount timeout

Never ran across that problem personally myself, but to start simple have you tried NFS mounting from the AIX system to the Linux system?

Also is the Linux Box in the etc/hosts on the AIX system??? Have you tried Mounting the NFS share from the Linux box via IP instead of hostname???

Just trying to gather some more info and maybe make some suggestions in the mean time..

RE: NFS mount timeout

There is two fs exported and mounted ok on my linux box.

All the /etc/hosts are ok on the two boxes and i also tried whit the ip address but the problem stil remains.

Looking at rpcinfo -p on the two machine, it seems to be good, i tried using tcp and udp but that's not different.

RE: NFS mount timeout

You need to start the portmapper on your Linux server.


RE: NFS mount timeout

as i said previously portmaper is started on the two servers

RE: NFS mount timeout

Sorry, we posted at the same time. Are you sure there's no firewall in between?


RE: NFS mount timeout

Ok i've found the problem but that's strange.

My linux box has two NIC and when i try to mount the file system on the AIX box using the linux's hostname, it doesnt work.

Using specificaly one of the NIC adress made it work but smitty had replaced the ip adress bye the hostname.

In conclusion rcp services seems to wait for connections only on one of the two NIC.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close