×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Setting a Report Parameter to a field from a Oracle table

Setting a Report Parameter to a field from a Oracle table

Setting a Report Parameter to a field from a Oracle table

(OP)
I have a report that should default to
a user's default location:
so, i have the following code, but
i am getting errors.

SQL ORA
select t.locationid AS ORG_STA from tr_user_master t
WHERE Upper(t.userid) = Upper('&MRUSER');
TABLE FILE SQLOUT
PRINT ORG_STA
ON TABLE HOLD AS HLDFIELD FORMAT ALPHA
END
-SET &ORIGIN_STA = '&HLDFIELD.ORG_STA';

Thanks,

Leo   

RE: Setting a Report Parameter to a field from a Oracle table

What's the error you're getting?  By "default location" do you mean the Oracle SID?  Does the SQL work in SQL*Plus?

RE: Setting a Report Parameter to a field from a Oracle table

(OP)
The SQL returns the correct "default location".
The default location is just a default parameter for
the report.

The problem occurs at the -SET &ORIGIN_STA = '&HLDFIELD.ORG_STA'; line

The error states that it doesn't recognize the '&HLDFIELD.ORG_STA' field.

Thanks,

Leo   

RE: Setting a Report Parameter to a field from a Oracle table

That -SET statement doesn't make sense.  If you're trying to set a WebFOCUS &variable to the returned value of the Oracle column, see my reply to your other posting.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close