×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

stcdgwtcpiphl7.exe treats external-generated ACK as unexpected data

stcdgwtcpiphl7.exe treats external-generated ACK as unexpected data

stcdgwtcpiphl7.exe treats external-generated ACK as unexpected data

(OP)
I have used stcdgwtcpiphl7.exe in moving from DG 3.6.2 to eGate 4.5.3 to save development time but it hasn't worked!!  Have got past various problems but this one has left me completely stuck:

Config file is as per (working) DG version, specifically "Forward External ACKS to Datagate Server" is set to YES.  This is an OUTBOUND eWay/comms client.  However the reply (ACK) is "unexpected data" on eGate (but not on Datagate), so it treats it as a NAK and takes its recourse action.  

I am running eGate on XP (connecting to an HP box).  Any help would be greatly appreciated,
Marco

Excerpt of reply bit of logfile below:
14:55:04.484 EWY  I 3008 (logging_compat.c:131): Incoming message from external: Len = [889] <MSH|^~\&|...<snip>
MSA|AA|...<snip>
14:55:04.484 EWY  D 3008 (logging_compat.c:215): Found MSA segment in message...further check if it is ACK or NAK
14:55:04.484 EWY  D 3008 (logging_compat.c:215): Message identified as HL7 DATA
14:55:04.484 EWY  W 3008 (logging_compat.c:131): Received unexpected data from the external.
14:55:04.484 EWY  I 3008 (logging_compat.c:131): Treating the incoming message as an HL7 NAK.

RE: stcdgwtcpiphl7.exe treats external-generated ACK as unexpected data

(OP)
This was a known bug - fixed with ESR 54141

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close