×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Slow when connecting to Interbase

Slow when connecting to Interbase

Slow when connecting to Interbase

(OP)
Hi,

i bought an P4 2.6G with 512 Mb of RAM and installed windows XP with SP1. After that i installed Interbase 6.0.1.0. The problem is that when i try to connect to the local server in the IBConsole, it needs about 15 seconds to connect (i don't have any database registered under "Databases"!!). The same time is required to connect to a database (when it's registered). Why is this happening? Before this new computer, i had a Celeron 333 with 128 Mb of RAM and windows 2000, but it connected in a second!!

Thanx very much for any suggestions

RE: Slow when connecting to Interbase

"badukist" did answer similar question like this

"It is a known issue, that's why Borland chaged the default database extension to IB and for Firebird is FDB
The GDB extension is included in System Restore stuff, so any opening or update is slower, because changes are saved/logged by System Restore."

Changing the your own database name is easy, but also
the user-database name should be changed.
That is "isc4.gdb", it holds all information about
the users and it is always opened when you take a connection
to your database. Or so I think???

Does anyone know how to change "isc4.gdb" to "isc4.IB" so
that the server can still find it?

-Mika

RE: Slow when connecting to Interbase

Hi jure,
  I have the same configuration as your new one and I had the same problem. Thes solution is to turn off Hyper Threading in BIOS or to use Firebird. Interbase 6.0 does not support multiple processors and Hyper Threading technology.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close