×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

uninstall problem

uninstall problem

uninstall problem

(OP)
I am repackaging an application of PeopleSoft. Using the
installation takes place perfectly but  it can not be uninstalled. The original setup also does not have any entries in the AddRemove Programs group.   

RE: uninstall problem

If you have repackaged an application, I assume, you mean, you have created an msi.
Is it the msi, you cannot uninstall ?

RE: uninstall problem

(OP)
yes I am not able to uninstall the application installed by the MSI.

Many of the PeopleSoft applications are showing the same behaviour.

RE: uninstall problem

Ok, so the msi comes from PeopleSoft, its not somethigng you've created ?

Look at the components. The properties for a component could be to leave it on uninstall.

What happens if you run the installation twice ? Will it install normally the second time aswell ?

RE: uninstall problem

(OP)
I have created the MSI. The original setup does not make any entries in the AddRemove programs.

The installation takes place properly. While uninstalling the uninstallation goes on proprly but after the InstallFinilize action it starts Roll back action.

I saw the log file. the InstallFinilize action is returing 6. I think it should return 1.

thanx

RE: uninstall problem

A return value of 6 means:

"A handle is in an invalid state." or ERROR_INVALID_HANDLE_STATE

Are there any scripts running in the install phase? If there are, check their processing options (on the scripts properties tab), if it is only set to synchonous then you may get this error, try setting it to snych, ignore exit codes.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close