×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Palm Vx / Nokia 7160 - Modem command error

Palm Vx / Nokia 7160 - Modem command error

Palm Vx / Nokia 7160 - Modem command error

(OP)
Hello all - I have a Palm Vx and a Nokia 7160 phone with Cingular 'My Wireless Window' service. I cannot get the Palm to dial my ISP via the 7160. I do have data transfer enabled ('My Wireless Window') and my connection Preferences are as follows:

Connection Method: IrComm to Modem
Dialing: TouchTone
Volume: Low
Speed: I've tried various speeds from 9,600 to 38,400 - I've seen a number of suggestions here. Which is best?
Flow Ctl: Automatic
Init String: I've tried 'ATZ', 'AT&F' and I've left it blank.

My Connection Details (although I'm not even getting this far) are:

Connection type: PPP
Idle timeout: Power Off
Query DNS: ticked
IP Address: Automatic ticked
No Script

Here is what happens when I tap 'Connect' on the Palm:

1 - The Palm reads that is is dialing my ISP and the phone reads,'Connecting...'so Ir connectivity is good. The phone will then read 'Data Call' for about 3 seconds.
2 - The Palm then reads 'Retrying' and the phone beeps and reads 'Data Call
Canceled', then 'Connecting...', and again 'Data Call'.
3 - I then receive the following error on the Palm:"
"Error: Modem command error. Check modem preferences (0x1105)"
The phone continues to read 'Data Call' until I end the call or it times out.

I was able to set up my 7160 as a serial modem on my Windows 2000 box to dial my ISP here in Connecticut. It worked perfectly. Therefore, data transfer is working and there's nothing about my ISP or Cingular's data network (at least in my area) that is causing the problem. I think it's some problem with the setup on the Palm, perhaps an incorrect init string.

Has anyone been successful getting a Palm to connect to an ISP via a Nokia 7160, especially on Cingular's network? If so, what settings did you use? Can anyone help with the correct settings for this configuration? Thanks!

Greg

RE: Palm Vx / Nokia 7160 - Modem command error

(OP)
According to Nokia Customer Care, they are aware of this problem and even stated that they know this seems isolated to Palm devices, as the 7160 works fine with laptops. Their R&D department is working on this issue and is communicating with Palm to develop a fix.

I would suggest to anyone who is experiencing this problem to call Nokia to report the issue at 1-888-665-4228 Menu option 1 then 2 then 3. That way they will be fully aware of the extent of the problem and hopefully expedite finding a solution.

RE: Palm Vx / Nokia 7160 - Modem command error

Any new news on this one?  I have just found myself with the same problem.

RE: Palm Vx / Nokia 7160 - Modem command error

I have a Nokia 7160 and a Handspring Deluxe. Using a third party software program called IrLink 1.5, it works flawlessly as long as your service provider uses digital data transfer. MCI so far doesn't along with AT&T and others in my area. Only Cingular has this in the Concord area of California.

When I used MCI, I got 8 beeps from the Nokia, which customer service from Nokia states the phone is telling me that no digital data transfer capability is found.

Now that I have Cingular (the only digital data transfer provider in my area), it works perfect!

RE: Palm Vx / Nokia 7160 - Modem command error

I also have the same problem with a 7160 (cingular) and a IIIx I have called palm and nokia and they both say they are working on the problem  

RE: Palm Vx / Nokia 7160 - Modem command error

Hello,

Thanks again for contacting us.

It sounds like the problem you are having is from the AT command ATS7.
It seems that Some PDA devices have this set to 90 where as some
Network
service providers have it set to 50. Due to the fact that they are
different you will get a Command Modem error message.


I hope that you will find this information helpful.  However, should
you
require further assistance, please feel free to let us know.

Sincerely,

LeAnn
Customer Care
NokiaUSA

when asked about a fix/workaround they said they "are working on it" and when they find it it will be posted on nokiausa.com, where I have no idea if anybody can code a new network panel or edit the palm os one with the ats7=50..... I tried to use it as a init string and the phone did less than it did with no init...

RE: Palm Vx / Nokia 7160 - Modem command error

Hi,

This is the ATS7=90 problem.  The default settings in the networks are *supposed* to be 1-255 seconds, with a default of 50 seconds.  However, many carriers have limited it for some reason (with all network vendors as well) to 50 seconds as the max- not just the default.  Many PDA's set the value to a higher number, and this generates an error on these networks (Compaq sets it to 120 seconds).

The carriers can adjust the value, and probably all aren't aware of the problem- so call them and let the know about it.

The other issue with Palm is that, by entering ATS7=50 in the Init string section, it is *supposed* to override the hard-coded setting.  It doesn't, and that is a bug (I have talked with Palm regarding this as well).  I wouldn't count on a fix to be forthcoming- their suggestion was to write a small app that would poke a new value in the Palm's network settings database.

The main hope is that the carriers fix it in the network, because the valid range is 1-255 seconds (per the TIA/EIA-136-350 standard).

Cheers,
Jeff

RE: Palm Vx / Nokia 7160 - Modem command error

One more thing- there are details at www.tekreview.com regarding this, and has some technical terms you can tell your carrier as well.  One word- the *611 operaters don't know much about data services (call it circuit-switched data).  The setting that needs to be changed is in their IWF (Inter-Working Function)- that's the bank of modems that makes the real-world connections to dial-up modems (even with their quick-connect, or ISDN connections).  All the base stations in a region connect to this IWF, so you can roam around and maintain one dial-up link.

Cheers,
Jeff

RE: Palm Vx / Nokia 7160 - Modem command error

I hope this issue gets resolved im gonna call cingular asap with my complaint and start hurrassing them now also, It would be nice if somebody would write an app to fix this even after I read the tekreview.com stuff I doubt cingular is in a hurry to fix it, a nokia rep told me that cingular dont wanna change it cause it will eat up to much time on the net'

RE: Palm Vx / Nokia 7160 - Modem command error

I have the 7160 phone with cingular wireless.  Can you give me some advice on setting it up to dial my ISP using windows 2000.

thanks

RE: Palm Vx / Nokia 7160 - Modem command error

I too am having trouble connecting with my Handspring Visor to my ISP through my 7160 with Cingular.  I can connect through my laptop (Windows 2000), but not the Visor.  I am not too happy about this since the connectivity was the primary reason I went with this phone model.

I have tried using the following modem strings with the IrLink software:
AT&F
AT&FV1E0&D2&S0&C1S0=0S7=60S35=7

However, neither works correctly.  The phone starts to dial and then the software on the Visor retries the connection and finally I get a "Check Modem" error.

RE: Palm Vx / Nokia 7160 - Modem command error

HELP!!!!!!!
I still havent even gotten a response from cingular about this issue, I have sent 4 emails to customer support and called *611 twice and was told that an "engineer" would get back to me...


If anybody out there can write code and would like to write a fix for this let me know, cause I doubt cingular will ever fix it

RE: Palm Vx / Nokia 7160 - Modem command error

I NEED SOME HELP. I HAVE A CASIO CASSIOPEIA EM-500 AND A NOKIA 7160. CONNECTION VIA IR WONT WORK. DONT KNOW WHAT IM DOING. ANY INFORMATION WILL BE GREAT. LIKE WHERE TO START. I GET IT TO CONNECT AND START TO MAKE THE DATA CALL, BUT IT SAYS NO CARRIER. OR NO DIAL TONE. OR A BUNCH OF OTHER THINGS.

RE: Palm Vx / Nokia 7160 - Modem command error

I have a palmIIIc and Nokia 7160 phone using the cingular network and I got the phone to dial and connect to my ISP first time, right out of the box. I also got it working with the cable today. It only connects at 300 baud :( but I'm working on that one. If you need details, just reply to this message and I'll come back and post them (It's 12:11 and I'm tired :)

qurgh

RE: Palm Vx / Nokia 7160 - Modem command error

SO as I expected due to the popularity of the 7160 the list of people is quickly getting longer...
I hope all of you have emailed cingular and called *611, if U haven't DO IT NOW!! they won't fix it till enuff of us complain... we all have the same issue lets work together to fix it...
here is the response i waited a month to get for cingular
--- "*******, ******* (SWBW)" <Stephanie.Russell@cingular.com> wrote:
> Dear Customer,
> I received your email regarding the ATS7=90 problem
> with our system.  I am
> not part of our technical team, but I have forwarded
> your email to several
> different departments which work with those aspects
> of our system.  I will
> reply to you via email once I have received an
> answer to this situation.  If
> you have any further comments or wish to adjust your
> account, please feel
> free to contact our Customer Services department at
> 1(800)234-9666 or 611 on
> your handset.
> Thank you,
>
>  *****************
> Cingular Online Customer Care
> 15901 E. Skelley Dr.
> Tulsa, OK 74116

RE: Palm Vx / Nokia 7160 - Modem command error

I've been watching this thread for several months now.
I work for an ISP / Wireless company, and we are willing to change the settings in our system to make this work, but our guys need more information on how to fix it.  I've gone so far as to print out this thread and highlight the important bits for them, but they still need more info.
If anyone can help I would appreciate it!

Thanks,

Frosty

RE: Palm Vx / Nokia 7160 - Modem command error

I would be happy to help in anyway possible, I have been connecting my palm wirelessly for almost 2 years now (I was on sprintPCS) but I haven't been able to since I "upgraded" my phone to a 7160 (a phone designed with data in mind).I have spoken to a alot of people from all of the companies involved (nokia,palm,cingular)and none of them new anywhere near as much as I do...I hate to toot my own horn but, toottoot

anyway I would lend a helping hand
Matthew Jones
bhang657@yahoo.com

RE: Palm Vx / Nokia 7160 - Modem command error

MANY THANX TO JEFF LEE FOR A VIABLE WORKAROUND!!!!
nokia-7160@groups.yahoo.com
join the e-group->go to the files section->download gsmtool->read my post on how to connect...GOOD LUCK
after almost 4 months it works :)

RE: Palm Vx / Nokia 7160 - Modem command error

Hello again to all,
  I am here now with some more new and more problems. It seems that Cingular had some little secrets that they were holding back. To start off they have some kind of contract with Yahoo.com. This contract says that yahoo is the only messenger site viewable by there wap service. All the rumers about the software version needed to be updated is bogus, becasue aol/icq/hotmail all wont go through there wap portals. Also any site that will give you a portal to conect through them to these sites is blocked as well. Also per my conversation with a very informative Nokia tech suport representive, she told me that Cingular flash programs these frogs (Nokia 7160's) so that you cant do much to em. I tried to add manualy another dialup instead of My (Crapy) Wireless Window by going to Menu-->Services-->Settings-->Connection Settings... According to the Nokia rep she said that when you goto Set 2,3,4,or 5 that there should be more options in them (edit, delete, in additon to option that is already there "activate". It seems that Cingular does not want users to enter ther ISP's and connect though free wap portals. No this is understandable if you dont pay for the service, but we are paying to be locked into there propierity wireless window. Thanks for listening to my 2 cents. If any one can figure out how to program set 2,3,4,5 please post, or better yet email me directly at Methogod@aol.com.
  Now I have a question that needs some expert advice. I just got my cable for my Casio Cassiopeia pocketPC (Em-500). I have tried over 100 times to connect via the cable to my data cable (DLR-3P) to my 7160. I get it to dial out or at least it says that it is "connecting..." for about 3-5 seconds, then it goes to say "DATA CALL..." I have had that on the screen for anywhere form 2 seconds to almost 20, but in every situation my Cassiopeia give me the same error message "No Carrier detected. Verify phone number and then try again". No I know its not my phone becase it works from my laptop and from my windows ME box. I am stuck and ready to jump. I would be really pissed if I payed a dime for either the phone or the PDA, but I guess the technology will get there soon enough, maybe as soon as someone replys with the solution to this problem. Its funny how I can make 500 computer work in a very complicated network but can get online on a stupid PDA. HELP HELP. Again this one was kinda long and if you still reading and have an answer please post it, there are many out there needed help with this, or just email me what you know, again, at Methogod@aol.com

RE: Palm Vx / Nokia 7160 - Modem command error

maybe im getting somewhere...
Mr. Jones:

        I apologize for not getting back to you sooner. Thank your for bringing this
problem to our attention. I have researched your problem and have forwarded your
information to one of our analysts in our network department. I expect to hear from
him soon. I also asked him to keep you abreast of the situation as well.

        Thank you again for your information. Please be patient as our network
department will likely need to determine if the change you're requesting will not
have a negative impact on the other services we provide to our customers.

        We know you have choices. Thank you for choosing Cingular Wireless!!

joe schmoe
Special Operations
Cingular Wireless Customer Service

RE: Palm Vx / Nokia 7160 - Modem command error

bhang,

Could you send me the information you sent to Cingular?
I would like to show this to our techs at our switch to fix this problem in our system.

My email is: frosty@wcc.net

Thanks!

Frosty

RE: Palm Vx / Nokia 7160 - Modem command error

i sent a copy of the email I sent cingular but it says no more than this thread does...

I cant seem to get Gsm tool to give me a working tcp/ip stack, but I think it has to do with the fact that im running an os4 rom for a V, which should be the same as the rom for IIIx but it works for jeff and that is the biggest difference between us.

im gonna try to reflash my device with a IIIx os4 rom or just switch back to 3.5.2 im not sure yet, and last time I tried to reflash I had probs with my laptop maintaining the connection to the palm during the flash and it took me almost a week to get a working rom flashed to my device???(everytime I have to reeboot I wonder why im still running a Microsoft product on any of my machines...)

RE: Palm Vx / Nokia 7160 - Modem command error

I have had the same problem.  I called and e-mailed everyone (Nokia, Palm & Cingular) several times each.  Every time I get a different answer.  The main theme is they are working on it.  Did I see something in this thread that someone has a work around?  If so please respond.
Rick

RE: Palm Vx / Nokia 7160 - Modem command error

Hello people. I´m also having a very weird problem
with my 7160. Anyway, I live in Sao Paulo and I´m
trying to connect my Clie to it, via IR port. I can connect,
that´s cool (data calls works fine). I can even send and
get emails, but surfing the web is a frustrating experience.
It starts to navigate but it stalls after a few kbytes loaded. At least, I can see the websites titles on the top :) The 7160 works fine with my Vaio´s IR port, but
it seems to act different with the palm device.

I´ve also bought the 7160 for the unique reason of
portability, so, I´m in the same situation of you all.

RE: Palm Vx / Nokia 7160 - Modem command error

still no reply from cingular...

CALL *611 AND COMPLAIN
EMAIL CUSTOMER SUPPORT AND WHINE

They will fix it faster the more people it affects, dont assume everybody else called, pick up the phone and yell until somebody hears you!

RE: Palm Vx / Nokia 7160 - Modem command error

I MUST keep this post alive...

I have had my 7160 for almost 6 months and it still wont work as a modem for my palm...

Palm ignores my email(or says the 7160 is not supported by the MIK and the MIK is the only way to use a cell phone as a modem on a palm device)(M505?? qualcoms pdaphone??)
cingular ignores my email( or tells me that they have to upgrade thier software and that wont happen till 2002)

I am MOSTLY frustrated because this is just a matter of changing a 2 digit variable, the palm wont override the hard coded value, cingular refuses to act in accordance with thier industuries standards and allow the ACCEPTABLE value the palm sets {ATS7=90} cingular ONLY allows values under 50 the standard is like 20-255 or sumthin (its further expalined back in this thread better than I could ever explain).

WHY can't this get fixed....
WHY can't somebody who can write code at palm or cingular just write a small system hack or somthing, for PLUCKS sake it is just a modem init string!!!!

im not the only idiot who cant write code that wants this fixed, I would hope somebody (preferably the PLUCKS who make the money from my PALM IIIx and my NOKIA mobile  phone on the CINGULAR network)

6months on a problem this small is SAD

RE: Palm Vx / Nokia 7160 - Modem command error

sigh... this seriously sucks!

at least one cingular rep is being ince and helpful :)

RE: Palm Vx / Nokia 7160 - Modem command error

I have the solution to the Palm Cingular Network Timeout (modem error x1105) error!
I got tied of waiting on Palm or Cingular to do something, so I did some further investigating with the diagnostic tool I developed to watch the transmission between the devices. The solution is actually quite simple and will integrate with the Palm seamlessly one implemented!

got to the following link: http://www2.mowery.com/PalmCingular/index.htm
and check it out

RE: Palm Vx / Nokia 7160 - Modem command error

I wish I could say here is what you need to do but I can't.

Cingular says they are aware of the problem and they are trying to get it fixed in all market this year(or so they say) read back thru this thread and you will get a good idea of the problem you can also check out my 7160 user group at: groups.yahoo.com/nokia-7160/ there is some more info there and even a few work arounds,(although they dont work very well)

Most of all CALL *611 and complain if they dont think the issue affects enough customers they wont fix it, I have had a big problem even getting responses to my  emails so be persistant

bhang
mod. nokia-7160@groups.yahoo.com

RE: Palm Vx / Nokia 7160 - Modem command error

Bhang, could you not get this to work in OS 4 (4.1)? I just received my upgrade to 4.1 and haven't had time to install it. Want to make sure I fully back up my working system before I try it.

I would think the fix would work for any OS greater than 3.3 and you could probably use the "OO" telephone number and script described for the IIIe at http://www.mywirelesspalm.com/palminternetguide.htm
to make it work.

Let me know if you get yours to work!

Tom

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close