Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

mysql settings / varibles

mysql settings / varibles

mysql settings / varibles

From the documentation I have found relating to mysql the main configuration file should be the file safe_mysqld

I am trying to disbale one of the default varibles


My server is co-located off site. For security reason I do not want any outside clients trying to attach to port 3306.

I simply want to disable mysql from running a socket connection on port 3306 or any other port ! Having it open seems to be a liability.

How can I disable it once and for all.

I tried commenting out lines in the safe_mysqld file. It did not make a differnce ?

I need some help on this one !

I am at my wits end !!!!



RE: mysql settings / varibles

If you disable all of mysql's ports, nobody will be able to use it, not even you.  If that's what you want, then I'd just stop the deamon completely.

If you only want to prevent external access, you could firewall off port 3306, or, if their is a command that controls which IP address MySQL listens on, just make sure it only says "localhost"


PS: If you're using a Linux system, ipchains will firewall for you.  Something like "ipchains -A input -s 3306 -j DENY"

(That's from memory so check it out to be sure)  If it's on windows, I'm not sure of the best solution, sorry

RE: mysql settings / varibles


I have recompiled mysql without network support. It functions just as did before with a few differcences.

1. No external DB connection on port 3306
2. NO TCP/IP connection to mysql
3. When calling the local DB you must call "localhost"

I have it up and working.


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close