×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

CVSNT - failed to create lock directory

CVSNT - failed to create lock directory

CVSNT - failed to create lock directory

(OP)
To anyone that can help me with this, I will be *ETERNALLY* grateful.

I am using the JavaCVS(http://javacvs.sourceforge.net) classes to interface with a CVSNT repository. Checkout, and version fetching are working, however when I try to add a file I get -

"cvs server: failed to create lock directory for `C:/cvsrepo/test/CVSROOT/Emptydi
r/DXTEMP/CVS/CVSTest' (C:/cvsrepo/test/CVSROOT/Emptydir/DXTEMP/CVS/CVSTest/#cvs.
lock): No such file or directory
cvs server: lock failed - giving up
cvs [server aborted]: lock failed - giving up"

The CVS repository is located in c:\cvsrepo, with a repository root defined at /test. So why, I wonder, is it trying to create a lock at 'C:/cvsrepo/test/CVSROOT/Emptydi
r/DXTEMP/CVS/CVSTest'?

The strange thing is, that if I run this same code from my home machine, accessing the repository remotely via the internet(using pserver) it works?! so it only occurs when I run the code on the same machine as the CVS repository resides on.

Has anyone come across something like this, or have insight into what might be causing it?

Thanks HEAPS in advance :)

RE: CVSNT - failed to create lock directory

Similar situation occurred with us, below is what was done and helped.

Created a Directory called LockDir

Edited the Config file under CVSROOT and changed to below.

# Put CVS lock files in this directory rather than directly in the repository.
LockDir=d:/CVSREPO/LockDir

Not sure if this will help in your situation but thought I should give you theinfo.

Also needed to get rid of all the locks the files with # inside CVSROOT. (Can't remember if this was a subfolder or not)

RE: CVSNT - failed to create lock directory

The other reason you'll get this sort of message is when cvs doesnot have write permission in the CVS repository.
This usually happens, at least on linux systems, when CVS is not the primary group of the individual who commited the module.

In plain speak, check the group owner and permissions.

Rgrds Peter

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close