×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Application won't display all linked records.

Application won't display all linked records.

Application won't display all linked records.

(OP)
I have a Clarion 5 application running on Windows95/98 with an odd problem that I haven't resolved. This is a simple application with 2 related tables. It's been in use for about 3 years. The parent (customer) table contains 14000 records with about 8000 related (event) records.  After selecting a customer from a list table, you are presented with the customer data screen which includes an embedded browse table showing all recorded events for that particular customer - pretty straight forward.

The problem is that SOME (not all) customer records will not display the related events on the embedded event table.  However, if you browse the Events table, all records including those that did not show up are there.  Even if, from a Customer record, you hit insert and add a new Event, the new event record is not displayed in the table.  But it is displayed if you, again, browse the entire Events table. So, the record was posted to the events table but it won't display in the embedded browse list on a Customer record.

Conversely, if you select a customer record where the related events DO display and add an event, the event DOES display as it should.

It looked like an index problem or corrupt file. So, I've run TPSFIX and reindex through TOPSCAN. I've stripped out the entire application (on a copy of course!) and let Clarion create a new application with a NEW data dictionary created with the 2 data tables.  Problem remains.  The affected records behave the same.  The good records work fine, the bad continue to work bad.

I'm out of ideas

Sgreer

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close