×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Directx Games lockup PC

Directx Games lockup PC

Directx Games lockup PC

(OP)
Specification:

CPU: AMD DURON 900
GRAPHICS: Geforce3 Ti500/Detonator 45.23
MOBO: ECS K7S5A/SiS735 Chipset/Latest ECS BIOS update
OS: XP PRO/SP1
PowerSupply: 300W

Ok, the last thing I remembered doing was the Graphics Card, and then the PSU. I had to buy a new PSU as the fan stopped working after I inserted the new Graphics Card.

More on the problem, is that any game I have tried so far, will lockup just before it is about to render some directx stuff. Some games I can view the menu, some can't but soon as game play is about to start (lockup central)

The Sims Deluxe works OK. Tried Freelancer, Starwars Wingcommander, a couple of others and they lockup when there is any rendering to do?

RE: Directx Games lockup PC

(OP)
OK, I think I have found the solution myself. Did the following:

- In dxdiag/Video section: Disabled AGP Textures option
- In Geforce Display Properties changed all the major Direct3D settings to average (not Performance of Quality, just middle)
- Changed the refresh rate of the display to 60Hz

I loaded up Star Wars Commander and it worked. Hoorah.

Only problem is, I am now not sure what exact thing that I changed made the difference. Egg!

I will reverse the changes one by one to find my 'Tweak'

RE: Directx Games lockup PC

(OP)
Ditched the Geforce Card. Bought an ATI Radeon 9600PRO. Still had the same problem. Apparently Microsoft have admitted there to be an issue regarding DirectX and AMD Platforms

Search for the patch named: Q321178_WXP_SP1_x86_ENU.exe to see if this works for you

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close