×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

OE tax error

OE tax error

OE tax error

(OP)
I'm developping and order input form with the xapi...

Everithing seems to be alright except for execution time
but for now my concern is on the tax calculation...

I have some miscalculation with the xapi, so i try to created a order with accpac directly just to be sure the probleme is in my code...

but the fact is that when i create an OrderEntry with accpac the seconds item(parts) detail have a wrong basetaxe for the second taxe (tvq)(quebec canada, using tps and tvq taxe)

** the right way to calculate this

10$ * 0.07 = 0.7 (tps)
0.7+10 = 10.7
10.7 * 0.075 = 0.8025 (tvq)
10.7+0.8025 = 11.50
total : 11.50
tx total : 1.5025



*** IN ACCPAC
taxebase1 (tps) 10$      good
taxeamount1     0.70$    good
taxebase2 (tvq) 21.30$   bad (should be (10.70$))
taxeamount2     1.60$    bad




Ive done this 10 times and with different customer using the same tax class...

if i post the OrderEntry then ship all and print the invoice.. still the wrong tax amount.....

I'm preaty sure the customer and taxe class are ok  because i double check them with a ACCPAC consultant...
And the first item(parts) have the right amount of taxe...

That is realy strange....
and if the accpac OE don't work properly  i cannot validate myself on my xapi code...

if someone have an idea...

thanks in advance

my ACCPAC consultant would probably support me on this, but i seek the solution for myself too

RE: OE tax error

(OP)
I found the solution,

In Common service -> tax Service --> Tax Group

Choose the tax group...
Set the Tax Calculation method to 'Calculatetax by detail'
instead of by summary...

for thoose who might have the same problem...

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close