×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Help needed with viewing all tables by refreshing connection

Help needed with viewing all tables by refreshing connection

Help needed with viewing all tables by refreshing connection

(OP)
Could someone please tell me why I cannot view all tables in my database even after refreshing the connection in my report? HELP!
Here are the properties of my database file:

Server Type=Microsoft SQL Server
Server Name=USCTDB01
Database=OMS
User ID=ReportUser
Database DLL Name=pdssql.dll
Server Type=Microsoft SQL Server
Datasource Type=SQL

Even the existant report I have won't let me view the tables it accesses inside the OMS database. I need to create another report to access another table in the same database but everytime I refresh the connection it still won't work!!! I cannot see all tables inside the database named OMS. Please tell me what to do! Thanks for any help offered in advance!

RE: Help needed with viewing all tables by refreshing connection

It sounds like a permissions problem. Try logging in using an Admininstrator account.

Also check to make sure that you have the proper data object type (Tables, Views, SP's, etc.) specified under options.

-k

RE: Help needed with viewing all tables by refreshing connection

(OP)
I have checked the permissions on the OMS database in question.....I have set it to open with a UseriD ReportUser....and when I had created the earlier report I could view all the tables. This was a week ago. Now when I want to use the same database but different tables it doesn't not display the table names for me to select them. If I refresh the connection it only shows me 3 tables.....2 of them are system tables. This even happens in the first report I created though when I run it it runs fine. I checked the Options and it seems to be fine. IS there anything I need to specifically set in there? Could it also be someother problem? Please help. And thanks for replying Synapsevampire!

RE: Help needed with viewing all tables by refreshing connection

In the Options of the Data Explorer you can set a mask:

Table Name Like
Owner Like

If these are set then the results are limited.

Since the report runs fine using the same user/pw, then I'd suspect this.

-k

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close