×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Problem with FrameSets?

Problem with FrameSets?

Problem with FrameSets?

(OP)
I have a frameset that worked fine for some time untill I added another frame to the set.  When I added this new frame, suddenly the frameset loads oddly.  By this I mean that (with no repeating pattern) a frame will not load the page that it should (404 Error).  Then that page will end up in another frame.  The page from that frame will be moved, and so on.

Following is the good version of the FrameSet:


<HTML>
   <HEAD>
   </HEAD>
   <FRAMESET COLS="146,*" BORDER=0 FRAMESPACING=0 BORDERCOLOR="#808080">
      <FRAMESET ROWS="15%,76%,*">
         <FRAME NAME="frListNavigate" SRC="./pgTabsForQuery_queries.html" SCROLLING="NO" NORESIZE FRAMEBORDER="NO">
         <FRAME NAME="frList" SRC="./pgViewCannedQueries.html" SCROLLING="AUTO" FRAMEBORDER="NO">
         <FRAME NAME="frButtons" SRC="./pgButtonsForQuery.html" SCROLLING="NO" FRAMEBORDER="NO">
      </FRAMESET>
      <FRAMESET ROWS="44%,48%,*">
         <FRAME NAME="frUserQuery" SRC="./pgShowQuery.html" SCROLLING="AUTO">
         <FRAME NAME="frQueryResults" SRC="./pgQueryResults.html" SCROLLING="AUTO">
         <FRAME NAME="frQueryResultsButtons" SRC="./pgQueryResultsButtons.html" SCROLLING="AUTO">
      </FRAMESET>
   </FRAMESET>
</HTML>

Then everything goes wrong when I make this change:


<HTML>
   <HEAD>
   </HEAD>
   <FRAMESET COLS="146,*" BORDER=0 FRAMESPACING=0 BORDERCOLOR="#808080">
      <FRAMESET ROWS="7%,7%,76%,*">
         <FRAME NAME="frSelectGroup" SRC="./pgSelectGroup.html" SCROLLING="NO" NORESIZE>

         <FRAME NAME="frListNavigate" SRC="./pgTabsForQuery_queries.html" SCROLLING="NO" NORESIZE FRAMEBORDER="NO">
         <FRAME NAME="frList" SRC="./pgViewCannedQueries.html" SCROLLING="AUTO" FRAMEBORDER="NO">
         <FRAME NAME="frButtons" SRC="./pgButtonsForQuery.html" SCROLLING="NO" FRAMEBORDER="NO">
      </FRAMESET>
      <FRAMESET ROWS="44%,48%,*">
         <FRAME NAME="frUserQuery" SRC="./pgShowQuery.html" SCROLLING="AUTO">
         <FRAME NAME="frQueryResults" SRC="./pgQueryResults.html" SCROLLING="AUTO">
         <FRAME NAME="frQueryResultsButtons" SRC="./pgQueryResultsButtons.html" SCROLLING="AUTO">
      </FRAMESET>
   </FRAMESET>
</HTML>

The problem does not occur every time but sporadically.  Any thoughts

RE: Problem with FrameSets?

I don't know for sure, but maybe you have a error in
pgSelectGroup.html...

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close