×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Mapping Problem HELP!!!

Mapping Problem HELP!!!

Mapping Problem HELP!!!

(OP)
OK I appologize for the repeated posts, but I know of no other place to ask these questions.  I am having a problem trying to map two simple xml documents.  The structure of the documents is identical, and I am just mapping them one for one except using a uppercase functiod on the first field.  The map compiles with no warnings no problems, but when messaging picks up the document and tries to process it I get this error:

An error occurred in BizTalk Server.
 
 Details:
 ------------------------------
 [0x0139] The XML document could not be translated. The map specified by reference "http://RESSLERD/BizTalkServerRepository/Maps/GM2.xml"; failed. Verify that the map is up to date.

 [0x0140] The following channel configuration setting is not valid: "FIGoodsMovement"

 [0x013f] The server could not finish processing the document.

 [0x1730] Suspended Queue ID: "{7F0187B2-26D4-498D-8F02-241D1925B240}"

 [0x013f] The server could not finish processing the document.

     
I am at my wits end trying to get this to work, please help!!

Thanks,
Adam

RE: Mapping Problem HELP!!!

(OP)
Just a note:
If I remove all mappings and just have one constant value for the destination I still get the same error??!!

RE: Mapping Problem HELP!!!

(OP)
More details:

10 Minutes after each one of these failures I get an Info message in my Application Log that says that an MSDTC session timed out, tearing down the session.  They seemed to be related but I cannot find any problem with my DTC or any immidiate relation between the two.

Thanks again!!

RE: Mapping Problem HELP!!!

Here are several more things to try:
 
1) Restart the Biztalk Service on the Biztalk Server
If that doesn't resolve the problem...
2) Make sure the map file contains the latest changes made to the input and output specifications.  Replace source and destination specification in the mapper, recompile the map and save it to the webdav folder.
If that doesn't resolve the problem...
3) refresh all Messaging manager objects by going onto the Server and in the Biztalk installation directory, SDK folder, Messaging Samples folder, Refresh Messaging Manager folder, run the refresh executable and select to refresh all components.
 
Let me know how this works.

RE: Mapping Problem HELP!!!

Has there been a resolution to this error?  I am very interested since I am getting the same error within an automated channel/port, with a map that executes flawlessly in the development gui.  I tried all the suggestions posted previously, still, same error.

Thank you.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close