×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Client installation problems
3

Client installation problems

Client installation problems

(OP)
I'm currently testing sms2 and am having difficulty re-installing client. Things worked ok for a day or two then I started having problems at the client (too many issues to list here at the moment). What we have found is that we have difficulty re-installing a corrupted client machine (using smsman). The installation program says the install is complete, but no components are installed (they are enabled and configured on the server).
Also, after about four attempts at re-installation, I now get an access denied message when trying to uninstall the client(I'm using the aministrator login).

Any Ideas?

RE: Client installation problems

There are a lot of things that could be happening. You could be having mismatch of files, boundaries are not properly setup etc... In any event, You have to properly uninstall the client before you can re-install it successfully. Use the 20clicln.bat utility. This will properly remove all the files from the client. Then you can manually install it with smsman. Run smsman from the smslogon folder on the BDC or PDC subnet that the client is a part of. Maybe I can help you better if you provide a little bit more details

RE: Client installation problems

First, I would like to ask:
1. What Client Installation method have you turned on in the Site?  And; 2. What Discovery Method have you turned on?  And;  3. What Client Agents have been configured at the Site?  4. Is the client in the subnet boundary?

(4.) Check the client's IP address and make sure you are within the subnet boundary of your site server.

(3.) Check if you have enabled all of the Client Agents (not components) on the SMS Site Server in the Site node of the Admin Console.  The Client Agents are the executables that are installed on the client machines (hinv32.exe, sinv32.exe etc.)

(2.) If Microsoft Windows Networking Logon Discovery is enabled, then you have (presumably) modified your Domain Controller to include the client installation method (these features are co-enabled*).  This means that you can actually just double click on SMSLS.BAT in your domain controller's NETLOGON folder (\\%domaincontroller%\netlogon).  This will install the client without needing to use SMSMAN.EXE.

(1.) The setting above actually turns on Microsoft Windows Networking Client Installation method.  However, if you have not turned on any Discovery method, then you will need to enable this method.

As far as the Uninstall not working...what method are you using to uninstall?  20CliCln.bat, SMSMAN.exe?

RE: Client installation problems

MAke sure the SERVER and Workstation SERVICE on the Workstation is running. That will cause the Client to not install. If your running SP4 on the WS try reinstalling it.

RE: Client installation problems

I have had some problems with uninstalling client's recently
and what I did is detailed below
I deleted the following keys from the registry
(You have to be careful when you work on the registry)
HKEY_Local_Machine/software/microsoft/NAL
HKEY_Local_Machine/software/microsoft/SMS
I also deleted the MS folder on C:\Winnt
I deleted smscfg.ini also in c:\winnt
When you've successfully deleted all these services & stopping all sms client services. you must reboot.

You can now install fresh clients by running smsls.bat from a Domain Controllers netlogon folder or manually adding the smsls batch file to each users login script.

good luck

RE: Client installation problems

2
Make sure that if you're using 20CliCln that you get the latest version from Microsoft's web site.  It's in the SMS Support Tools pack.

Use the /SCRUB switch.  If the switch doesn't work you don't have the latest version.

Hope this helps,

Mike

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close