×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

.NET and DirectX components

.NET and DirectX components

.NET and DirectX components

(OP)
im a beginner to DirectX programing and i wanted to get started but im having trouble with the references. I'm using Visual Studio .NET and DirectX9 SDK. When I open sample code there are exclamation points on the references for microsft.directx and all the other components under that namespace. When i try to add them as references i cant find them anywhere in the list and i dont know where the dll's are to point them to it. I would assume that those would be installed automatically when installing the SDK. ive installed the SDK 3 times and installed everything locally and still I can't use the components. This is very frustrating and any help would be greatly appreciated.
Thanks,
Matt

RE: .NET and DirectX components

I have the exact same problem. I have tried all kinds of things and can't get studio to find the references. I went to the GAC and the assemblies are there, but the references still come back unfound. I think this is an issue of 9.0a va 9.0b, because I didn't have a problem with this until I installed 9.0b. I wish I could go back, but I can't. If any one finds a solution please post it. I am in the middle of a huge project and I'm gridlocked now.

RE: .NET and DirectX components

I solved the problem. For some reason Visual studio doesn't know where to look for the .dll files, but they are there. To make it find the files do the following:
1. click project -> add reference
2. click browse to:
(for windows XP) C:\WINDOWS\Microsoft.NET\Managed DirectX\v9.00.1126\(whatever library you are looking for)
3. click OK

Studio will tell you that it is going to change an existing reference. Just say ok and you should then be able to use the DirectX libraries as normal.

RE: .NET and DirectX components

Hi,

  I have same problem, however I tried the procedure, but could not find any dll libraries in the folder.

Any help?

Thank you


RE: .NET and DirectX components

I am not sure why its not working. Here are some suggestions. Make sure you have correctly installed the DirectX SDK.( A note on my problem listed above: I am using C#. I don't know if the fix would work in C++.)
   Try doing a search for "Managed DirectX". You should be able to find a folder that contains the DLL's.
   Try going to your Windows folder and looking in the "assembly" folder. Look to see if Microsoft.DirectX is listed. If not then you have not properly installed DirectX.
   The basic solution is to find the DLL's and point to them manually. If I think of anything else that might help. I will post it.

RE: .NET and DirectX components

Thank you darxpan! I had the same problem after installing 9.0a and was tearing my hair out. This solved it.

RE: .NET and DirectX components

hello everyone,

I am having the same problem.  I installed the Update 2003 version first.  Did I make a mistake?

RE: .NET and DirectX components

I finally resolved the problem after reading a post in another forum...
Accidently the SDK-Installer does NOT unpack the required .dll which is located in this dir:

C:\DXSDK\SDKDev\Retail or C:\DXSDK\SDKDev\Debug

the name of the archive is dxnt.cab (for XP I guess)

Just unpack it to the dir mentioned by darxpan and add the needed .dlls as a reference... now everyting should work fork, well at least for me it did ;)

RE: .NET and DirectX components

I am having a new problem, but it seems related.

I am making a new project using Direct3d. I added the nessescary references and it compiles, but when I run it I get System.IO error saying that Driect3D or one of its requirements was not found. It is listed in the Assembly folder. I have a working refernce to the .dll file, but for some reason it won't run.

RE: .NET and DirectX components

I installed the .NET 1.1 SDK and changed the System references to 1.1,  that changed the error I get. The program gets a little further before dying now. The screen comes up and I get an error saying that my application can't run using the active version of the .NET.
 
I can't find anything about this problem (what I found was related to C++ and I am using C#) and I don't really understand it. I have 1.0 and 1.1 both installed on my box. I am NOT using visual studio .NET 2003, but just visual studio .NET.

RE: .NET and DirectX components

From what I understand here is the problem and there is no good solution. First, DirectX 9.0b requires .NET 1.1 to work. To work with .NET you need VS 2003. So there is no solution without upgrading.

RE: .NET and DirectX components

Hi,I am also a newbie to directx sdk here,but I'm wondering why there are no item :"add to reference" under the menu "project"???

I am using Visual C++ 6 ,maybe old,but classic I think.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close