×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Netgear MR314 Router LAN

Netgear MR314 Router LAN

Netgear MR314 Router LAN

(OP)
Hi all,

Ive got two computers wirelessly linked to my MR314 router.  Both have unique ip addresses assigned to the network cards and can access the internet through the router.

I want to be able to transfer files between the two computers via the router but i have not been able to set this up

Neither computer can ping the others ip.  They can both ping the router (192.168.0.1) and ping localhost but fail to ping the other computers' ip.

i have the c drives shared on both computers and if i set the network connection up as an ad-hoc connection, the two computers can see each other.

what do i have to do to setup transfers between the two computers wirelessly ?  is there some software i can use to achieve this?

All help appreciated.

RE: Netgear MR314 Router LAN

can you post the 2 PC's IPs?

(dos command "ipconfig /all" will list the full settings)


<marc>

RE: Netgear MR314 Router LAN

(OP)
Firstly, thanks for the reply.

The ip's are as follows :

Router : 192.168.0.1
Laptop : 192.168.0.2
Desktop : 192.168.0.3
Server : 192.168.0.4

I am trying to use the server as my ftp server and transfer data i've downloaded on my laptop to it.  The desktop is another computer that I have.  I assigned an ip to it so that it wouldn't cause a conflict. ( so it has one rather than being given one )

On the router setup I have forwarded ports 20 and 21 to the server ip.  I have had someone connect to the ftp from an external ip and it works fine.

I have also turned off the dchp server option in the router setup, although i don't know if this was required or not.

Thanks.

PlymWS

RE: Netgear MR314 Router LAN

(OP)
Also, all the computers are on the same subnet mask 255.255.255.0 and have their preferred dns server as the router ip.  the default gateway is the router ip too.

RE: Netgear MR314 Router LAN

Hi PlymWS -

a few things spring to mind...

1.  The laptop and server are on the same subnet - normally pings WOULD NOT go through the router
2.  Wireless - can operate without a router....you should be able to transfer the file peer to peer without using the router...i.e. Ad-hoc...however, when set to infrastructure, peer to peer is normally disabled.
3.  Netgear's manual suggests that the router WILL automatically forward TCP destined for the same subnet.
(ftp://downloads.netgear.com/files/netgear1/MR314_refguide_326.pdf)


suggestions...

 apologies if you already know this - might as well touch on all bases!

a.  "the default gateway is the router ip too"
      Do you mean the router's LAN IP or WAN IP?
      The gateway should be set to 192.168.0.1 on all your PCs
NB The problem does sound like a gateway issue - try "ipconfig /all" (or running "winipcfg.exe") from your laptop to see the full network card settings.
Check that your network settings apply to the WIRELESS network card (if there's more than one network adapted, each adapter will have a different IP/subnet/gateway configuration).

b.  Check the router's LAN configuration...
    DHCP server should not be checked (you're using static IPs)
    It should have IP 192.168.0.1, subnet mask 255.255.255.0, RIP set to none, RIP Version set to RIP-1, Multicast set to None.

c.  Check your wireless lan settings - the router's ESSID should be the same as your PC's wireless card's ESSID.  It probably is (as you're connecting to the router) but it doesn't hurt to check.

Let me know if any of this solves your problem.
<marc>

RE: Netgear MR314 Router LAN

(OP)
Hi Marc,

Ive followed what you said and this is the result :

1. If I set up an ad-hoc network, I can transfer files between the two computers perfectly.  Obviously, this takes the router out of the circuit so the internet isn't accessible.

2. I'm using the LAN ip of the router as the default gateway.  When i run ipconfig /all ( i don't have winipcfg because im running Win XP Pro on both computers ) the only difference between the two computers ( apart from the obvious ip, mac address etc ) is that ip routing is enabled on the laptop, but not on the desktop.

3. The routers setting were as you specified by default so i had to make no changes there.

4. I have checked and it is the wireless card I'm connecting with and have assigned the ip to :)  The ssid is "wireless" ( router default ) and in the wireless card settings the ssid box has "any" in it so i would presume that the card would try and connect to every wireless network it could :)

Thanks once again for the reply.  Any more ideas ?

RE: Netgear MR314 Router LAN

a few more -
  have you tried hardwiring the laptop / server to the router?  I know it doesn't solve the prob, but might shed some light on where the issue is...try hardwiring just the server, then just the laptop, then both.  (assuming you've got Cat5 connections aswell!)
  have you tried disabling IP routing on your laptop?

try taking a look for any unusual entries in your laptop's routing table (command prompt - "netstat -r" or "route print")

Other than that...now running short of ideas...
<marc>

RE: Netgear MR314 Router LAN

(OP)
how do i disable ip routing ?

RE: Netgear MR314 Router LAN

I've come up with a few more thoughts before you take that step, so here goes...

  MicSoft says
To enable TCP/IP forwarding, follow these steps:
Start Registry Editor (Regedit.exe).
In Registry Editor, locate the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Set the following registry value:
Value Name: IPEnableRouter
Value type: REG_DWORD
Value Data: 1

A value of 1 enables TCP/IP forwarding for all network connections that are installed and used by this computer.
Quit Registry Editor.


So I guess to disable it, set Value Data: 0


 the other ideas :)
1.   Is MAC filtering set up on the router?

2.   from Netgear:
"The SSID is a common password unique to each Wireless network. Only those devices with a common SSID can communicate with one another on the network"

So your laptop can sign into any (accessible) router - perhaps not into the network though...is the server on a different SSID?


3.   check your firmware!
"MR314 Firmware version 3.29
Explanation:
MR314 Firmware version 3.29 in .zip format
Modifications and Bug Fixes:
Solved the bug of communication between wireless stations, via MR314."


firmware download site:
http://www.expressresponse.com/cgi-bin/progsnp/netgear2/srchjnnp?search_type=vdocument&search_input=D100271.htm&session_id=1045710831.21281.5&template=viewmoretest%2ehtml&page=7&search_erproduct=MR314

Does the router keep a log?  Show a status of devices connected?

Please keep us posted on your progress - this is starting to get fascinating!
<marc>

RE: Netgear MR314 Router LAN

(OP)
** SUCCESS **

Marc, you are a f*****G STAR :) !!!

I updated the firmware and it all works now.  I thought I was using the latest version but I mis-read the number on the router page :)

Anyway, thanks for all your help Marc.  Got there in the end, and I've still got some of my hair :)

Thanks again mate.

RE: Netgear MR314 Router LAN

pleasure m8 - glad to find an answer!  I was driving myself nuts thinking of possible issues
<marc>

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close