×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Need to ICS to work, server 2000 to laptop 2000.

Need to ICS to work, server 2000 to laptop 2000.

Need to ICS to work, server 2000 to laptop 2000.

(OP)
Hi,

I've got problems seting up Internet Connection Sharing.  I want to have 2 computers access my broadband connection by using my server 2000 as the host (which is connected to the ASDL modem)and my laptop as the client.  I have enternet broads enabled and they both talk using TCP/IP protocol.  I can ping each of the local I.P. addresses but can't ping an external i.p. address/domain name from the client machine.

The host machine has ICS enabled on the internet connection which also has TCP/IP enabled.  The setting for the internet are to obtain I.P. address and DNS automatically.  The internet connection is a static I.P. as the machine is a website server too.   

The Host etehrnet card is set to TCP/IP protocol and also obtains its IP setting automatically.

The Client ethernet card is set to TCP/IP protocol and also obtains its IP setting automatically.

I don't have DHCP enabled (because I don't know how to).

When I do IPCONFIG/ALL I get on the host:

Host Name : Share-k0o1446no
Primary DNS suffix :
Node Type : Hybrid
IP routing Enabled : Yes
WINS Proxy Enabled : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix :
Description : Accton EN1207D Series PCI
net Adapter
Physical Address : 00-80-2D-8F-CC-11
DHCP Enabled     : Yes
Autoconfiguration Enabled : Yes
Autoconfiguration IP Address : 169.254.78.244
Subnet mask :255.255.0.0.
default gateway :
DNS Servers :

PPP adapter internet:
Connection-specific DNS suffix :
Description : WAN (PPP/SLIP) interface
DHCP Enabled : No
IP address : 213.123.215.xxx
Subnet Mask : 255.255.255.255
Default Gateway : 213.123.215.xxx
DNS servers : 213.120.62.103
DNS servers : 213.120.62.104


If I do ipconfig/all on the client i get:

Host Name : share-ujpz42233
Primary DNS suffix :
Node Type : Mixed
IP routing Enabled : No
WINS Proxy Enabled : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix :
Description : SiS 900 PCI
fast ethernet Adapter
Physical Address : 00-A0-CC-CC-38-BE
DHCP Enabled     : Yes
Autoconfiguration Enabled : Yes
Autoconfiguration IP Address : 169.254.212.96
Subnet mask :255.255.0.0.
default gateway :  
DNS Servers :  

So what happens at the Clinet machine when I set IE6 to connect through a LAN (without anything set in the connection wzard) IE just displays 'The page cannot be displayed'.

Also I have Zonealarm enabled on both machines.  I've set the I.P. address range 169.254.0.0-169.254.255.255 to the trusted zone for both client and host and I've set the Host to be an ICS/NAT gateway on zonealarm, likewise the client I've set to 'this machine is a client of an ICS/NAT gateway running zonealarm pro'.

Can anyone start me off on some pointers or even better tell me what's wrong? [:)]

Thanks people,

mazza.


RE: Need to ICS to work, server 2000 to laptop 2000.

Check this: http://www.homenethelp.com/ics/index.asp

Additionally, the IP addresses you listed are APIP's (they aren't getting an address, so they give themselves one).  When you use ICS, it should set the IP of your private NIC to 192.168.0.1 and then will supply other computers on that side IP's via DHCP automatically.  The gateway it assigns will the the NIC at 192.168.0.1.  Thus the short version is, something isn't quite right in your congfiguration.

RE: Need to ICS to work, server 2000 to laptop 2000.

(OP)
Thanks!

Do you think it could be my DHCP?  I'm not sure how to set up the scope ranges and what to put for the gateway and DNS server etc.   Basically I have a laptop and a server and that's it I don't have a DNS server working on the network.  
Can anyone guide me through how to set up DHCP?  

I'm I right in thinking the scope range should be 169.254.0.0 to 169.254.255.255 or is it 192.168.0.0-192.168.255.255, I don't know what to do about the gateway and dns server through would this be 192.168.0.1?

Is there any other things I could check?

Cheers,

Mazza.

RE: Need to ICS to work, server 2000 to laptop 2000.

You would set up your dhcp addresses with the 192.168.0.0 address.  However if there are only 2 machines it would probably be an idea to give them both static ip addresses.  Also your server should have a static ip address anyway as that is the default gateway if it has the asdl attached to it.  I would recommend that you also install the DNS service onto the server as well to make things easier unless you know of another DNS server.

so your server should be set up something like this:

static ip address

address  192.168.0.1
subnet mask  255.255.255.0
Default gateway  192.168.0.1

Primary DNS  192.168.0.1 (if you install the DNS service onto you machine otherwise put the address of another DNS server)

Your labtop will be set up something like this

tick the "obtain an ip address automatically"

Primary DNS  192.168.0.1 (if you install the DNS service onto you machine otherwise put the address of another DNS server)

or

static ip address

address  192.168.0.2
subnet mask  255.255.255.0
Default gateway  192.168.0.1

Primary DNS  192.168.0.1 (if you install the DNS service onto you machine otherwise put the address of another DNS server)

Hope this helps

RE: Need to ICS to work, server 2000 to laptop 2000.

(OP)
Ah, okay I've tried that.  Bascially I've now enabled DHCP and set the zone to be 192.168.0.0 to 192.168.0.3 and I've set 192.168.0.1 and the gateway and dns server.  Also I've reset the trusted zones in zonealarm pro on both Host and client machines.  I've also enabled the static I.P. to the ethernet on the Host machine.   I've started the DNS server and set forward zone dns.shareaproperty.com, I set reverse lookup as 192.168.0.

Guess what it worked!  But only when I set both I.Ps to static.  Without the I.P.s both being static I got the dialogue error cannot find serach page.  Also the client machine did not pick up on the default gateway being 192.168.0.1 for some reason, any idea why so I can set it to be automatic instead of static?

Cheers you've been a star so far.

Mazza

RE: Need to ICS to work, server 2000 to laptop 2000.

For just a couple of IP's, use static.  I've got a machine getting a ip from Cable/Modem using dhcp, but internally, I give my laptop a static ip with a gateway of me desktop using a wireless router.  This allows me to surf the net without wires.  Good luck.

Glen A. Johnson
Johnson Computer Consulting
MCP W2K
glen@johnsoncomputers.us

Want to get great answers to your Tek-Tips questions? Have a look at FAQ219-2884
  
 "It's not what you look at that
matters, it's what you see."
         Henry David Thoreau (1817-1862); US essayist, poet.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close