×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Solaris webserver internet access problem w/ new ISP

Solaris webserver internet access problem w/ new ISP

Solaris webserver internet access problem w/ new ISP

(OP)
Hi,
I was running a webserver on a Sun system with Solaris 5.8 OS, and it has been running fine for a year with DirectvDSL as my old ISP provider with a static IP address. But, since the DirectvDSL business was closed out, apparently my only available choice that can provide a DSL connection  to our area is with SBC-yahoo ISP. So, now I've the 5-static IP addresses service plan.

Configuring the TCP/IP on my windowsXP PC with an assigned  static IP address works just fine, meaning I can surf the internet. Now, I realized that the SBC-Yahoo technical support group does not provide support for unix system.

      phone-wall <---> modem <----> WindowsXP     - OK

However, since I was able to make it work once with the DirectvDSL modem, so I thought of giving a try with the SBC-Yahoo "SpeedStream 5360" Ethernet ADSL Modem. But, now  after attempting to configure the TCP/IP on the Solaris system, currently I'm having a problem connecting to the internet.

  phone-wall <---> modem <----> Solaris/Unix  - Problem
     
One interesting to note is that I can ping the static IP address that I've assigned to this Solaris system as well as
the other 3 static IP addresses, including the static IP
address that is assigned by SBC-YAHOO as my default gateway. However, I cannot reach out or ping the assigned Primary/Secondary DNS servers  (63.203.35.55/206.13.28.12).
Hence, the solaris system cannot access the outside world.

Although, the webserver is still running fine locally, of course it cannot be accessed by outside users as there seem to be some kind of TCP/IP config setup. So, out of curiosity
I've tried connecting the running WindowsXP PC and the running Solaris/Unix webserver on a neatgear switch as shown
below.

                                   Netgear  8-Port FS108
 phone-wall <---> modem <--->  Fast Ethernet Switch
                                   o o o o o o o o
                    Windows Xp <---^   ^----  Solaris/Unix

The windowsXP PC can access the running webpage on the Solaris/unix system as well as access the linked websites
on the webpages. I think I've already exhausted all of my
little networking knowledge, and so I'm hoping that somebody
maybe able to provide me some pointers on how to fix my problem(s). I hope too that there maybe some Solaris/Unix system users in this forum who might be hosting their own website too with Sun system and run into similar situation and have fixed it already.

Sorry, for the lengthy posting. Any help will be gladly appreciated.

Thanks,
Novice network admin

RE: Solaris webserver internet access problem w/ new ISP

What do you have your /etc/defaultrouter file set to?  Is it set to the correct default gateway address?

RE: Solaris webserver internet access problem w/ new ISP

(OP)
Thank you very much for the help. Yes, after setting the default gateway address on my /etc/defaultrouter file, my solaris system can now access the outside world, and thus making my website being accessible by outside world.

However, there's one little problem that I'm having, that is, accessing the yahoo.com website. I can access pretty
much the whole cyber space except yahoo.com. So, just wondering if someone might know what the problem is.
By the way, inside my /etc/defaultdomain file I have
     sntcca.sbcglobal.net
as I live closeby Fremont/Pleasanton area. Maybe, I'm using
the wrong domain name?

Thanks again for the help,
Solarissbc

RE: Solaris webserver internet access problem w/ new ISP

I just did a ping on yahoo.com.  Recieved 66.218.71.198.  Try putting that in your browser and see what happens.  If nothing, then try pinging yahoo yourself.  Good luck.

Glen A. Johnson
Johnson Computer Consulting
MCP W2K
glen@johnsoncomputers.us

Want to get great answers to your Tek-Tips questions? Have a look at FAQ219-2884
  
 "It's not what you look at that
matters, it's what you see."
         Henry David Thoreau (1817-1862); US essayist, poet.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close