×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Application '' Failed to Launch, Debugging ASP on XP
2

Application '' Failed to Launch, Debugging ASP on XP

Application '' Failed to Launch, Debugging ASP on XP

2
(OP)
I would like to send some info regarding Visual Studio 6.0 Interdev and Remote Debugging on XP Pro.

The error message when starting debug in Interdev

Application '' Failed to Launch


Cause:
Microsoft Debug Machine runs as a service.
The service points to C:/Program Files/Common Files/Microsoft Shared/VS7Debug/MDM.EXE

(*) I assume that this is the .NET debugger that installs with ????

Resolution:

With in the  C:/Program Files/Common Files/Microsoft Shared/VS7Debug
directory.
Rename MDM.exe to OLD_MDM.exe
Rename PDM.dll to OLD_PDM.dll

then

Copy
c:\windows\system32\mdm.exe
c:\windows\system32\pdm.dll
to
C:/Program Files/Common Files/Microsoft Shared/VS7Debug

Visual Studio 6 will now start the correct version of the MDM which will allow you to debug ASP pages in Localmode.


I hope this helps!!

RE: Application '' Failed to Launch, Debugging ASP on XP

OMG!  Am I glad I ran across this post.  I've posted here before about the XP "Application " failed to launch" and found the solution to that on MSDN.  But I had to switch back to Win2k and had the same problem after installing .NET.  I've been working on this problem for 3 days.  I've uninstalled/reinstalled everything twice and reset system security and about 1000 other things. I was just about ready to reformat my drive and reload.

Thank you, Thank you, Thank you.

Doug

RE: Application '' Failed to Launch, Debugging ASP on XP

I just wanted to thank you so much. I , like others, have been struggling with this problem. Your solution works. I would only add that you need to reboot your PC after copying the files.

You are a life saver.

Thank you again!

Sergio

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close