×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Trying to load 3c920 drivers in ms-dos mode

Trying to load 3c920 drivers in ms-dos mode

Trying to load 3c920 drivers in ms-dos mode

(OP)
Dell Optiplex machines come with an integrated NIC a 3com 3c920. Dell does not make drivers for this card and they just state that it will work with the 905c drivers.

I am trying to load DOS based drivers for the NIC to lay down a ghost image from our network.

when the drivers load for the NIC I am getting the error "DOS TCP Resident driver Init failed"

subsequently netbind wil spit out

"error 33 unable to bind"

I have searched high and low and tried many different 905c drivers yet I have not been able to find the one that will make this integrated nic work under ms-dos.

any ideas?

RE: Trying to load 3c920 drivers in ms-dos mode

Is there any change you use Norton/Symantec Ghost for cloning computers? If so, I might be able to help you. I usually order Dell Optiplexes and clone them with Ghost, the network boot disk with 3C905 DOS driver works just fine. Well, nowadays Dell makes Optiplexes with Intel Pro 1000 NIC... :)

Now this might be a stupid question, but are you sure the NIC is functioning properly? I once spent several hours fighting with Ghost, then I finally found out the NIC was dead.

I normally create my boot disks with Ghost Boot Disk wizard, and the driver that seems to be working well came with Noston Gost 2002. If this is a Ghost isuue, which version are you using?

Regards, Noblehill




   

RE: Trying to load 3c920 drivers in ms-dos mode

(OP)
yup... the NIC works fine in windows, we have several machines of this model and they all do the same thing. I have tried using several different versions of the 905 driver and i get mixed results.. sumtimes this TSR will fail or using another driver a different one will.. would it be possible for you to send me a copy of the configs and files you use to get your machines up for ghost?
I am pretty sure i am setting up the config files up right but it's been awhile since I had to do this.

thx
-Steve

sk00basteve777@kikazz.com

RE: Trying to load 3c920 drivers in ms-dos mode

Dude, this is the first time I have used this forum so forgive the ignorence.  I wrote the doc about connecting a laptop to the network for PowerQuest a few years ago.  I am sure It can help you.  Do a search for connecting my laptop from dos on the PowerQuest support site. If you want me to fix it, I need the driver you are trying to use.  Can you zip it up and send it to me?  Not in exe form "Outlook won't let it through"... if you use WinImage www.winimage.com to send me the dos boot floppy I will test it here.  I have the same model, the 3com 3c920 integrated piece of *&@# from Dell.  By the way I hate Dell's crappy Invasive Web site. They make good computers but their support on the Web Site STINKS! (Ok enough ranting and raving)  My email is gbaird@januslogix.com (no spam please) :)

Gar Beotch

RE: Trying to load 3c920 drivers in ms-dos mode

Now if the driver is supposed to work but can't bind the card you have one of two problems. A its conflicting with another device (from DOS) Windows corrected this problem so don't look at me funny because I know what you are thinking! or and most likely OR Dell has given you the wrong information.  See, unless the driver actually has a record for device "3Com Integrated (3C920)" or something like it the driver will come back with error 33.  Not all is lost, I can probibally use a hex editor on the .com file and put in the right info to make the driver work.  Send me an email if you want to try it.  No guarentees but it has worked for me in the past.

RE: Trying to load 3c920 drivers in ms-dos mode

Ok I built an El90x.dos and then built a bootable CD that works (mine doesn't have a floppy drive)  If you are interrested my email address is in the first post.

RE: Trying to load 3c920 drivers in ms-dos mode

I am trying to clone some dell latitudes and when I f8 while loading my norton ghost it consistantly fails when trying to netbind. I get error 33 unable to bind. I have a DHCP and have tried setting up the boot disk as static and dynamic. I verified that the docking station worked on DHCP by connecting another Laptop and it booted fine. I cannot get "Multi-cast" to light up in the gui. I have downloaded new drivers from "Treks" above link and still no luck.

RE: Trying to load 3c920 drivers in ms-dos mode

I had the same error. Turns out that in the Protocol.ini file I had the DRIVERNAME= pointing to the wrong one b57$ and I needed e1000$ for the GX270 driver. Below the correct info was under [protman] but not under [ms$ne2clone]

below is an excerpt of the correct settings that worked.

[ms$ne2clone]
drivername=e1000$


[protman]
DRIVERNAME = E1000$
PRIORITY=MS$NDISHLP

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close