×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Can't uninstall Nortel Contivity VPN software.

Can't uninstall Nortel Contivity VPN software.

Can't uninstall Nortel Contivity VPN software.

(OP)
I work in a place where we need to accomplish the apparently impossible.  We need to actually have the ability to, brace yourself, connect to several different remote access servers and VPN servers from one computer.  That used to be easy when everything was dial up.  Now, companies (and in my case, hospitals) are switching over to internet based VPNs.  They're faster, sure, more secure?  I don't know, I guess so... but one thing is for sure, they are certainly a pain in the ass.

Hospitals started off using primarily the Cisco VPN client, which was okay, and it actually seemed to work.  Some hospitals were liberal in their access, even allowing local LAN access so the people in our office could do things like print and access network shares.  That used to be standard, but it seems they have tightened security, and allowing the computer on the other end to be able to do ANYTHING but communicate with the hospital's server is unacceptable.  (Which is of course all my fault as far as the end user is concerned)  Anyway -

I was setting up one of the remote access connections (that uses Cisco's VPN client) on a computer that already had the Nortel VPN client installed on it.  It told me I had to uninstall the Nortel VPN Client before installing Cisco VPN software.

OK - Well, after I did that, the user told me he actually needed Contivity back on his computer.

Great - So I reinstalled Nortel, and when I would try to connect to the VPN, I would get a socket creation error.  Not much help to the user, so I did everything I could think of... including trying uninstalling and reinstalling the Nortel Contivity VPN software.  When I tried to uninstall it, BAM:



Quite explanatory, eh?

So, I didn't know what to do.  I tried re-running the install program.  Got the same error message.  It wouldn't let me reinstall.

So, I tried removing the program files from "C:\PROGRAM FILES\CONTIVITY VPN" or whatever it was.  After I did that, I tried uninstalling it (as windows often removes things from the installed program list if it can't find them).  Nope, I still got the "catastrophic failure" error message.

I then tried uninstalling the Cisco VPN client.  It uninstalled, but didn't change anything.  Still got the "catastrophic error" message.

Then, just for the hell of it, I tried running Nortel's Contivity VPN client.  After windows searched for it, it opened... AND WORKED.  (I think the problem before was the fact that the Cisco VPN client was installed, so it was locking up some port or socket or something)  anyway...

When I looked at the properties of the Contivity VPN client's desktop shortcut, I noticed it was running from "C:\RECYCLER\S-1-5-21-1030561755-2085252849-1621235808-500\Dc1\Extranet.exe" - Which is obviously not the correct path.  It was apparent Windows searched for the files and updated the shortcut on its own because it couldn't find them.  Problem there is - I can't even browse out to that location to restore or permanently delete it.

I guess I could use it from its current location, but that doesn't seem like the greatest of ideas.  Has anyone seen this "catastrophic failure" message before?  What exactly am I supposed to do?  I can't reinstall it, I can't uninstall it, and I can't install the Cisco VPN client on the computer either (because it doesn't let you install it while Nortel's Contivity is installed).

Ugh... What do these companies expect the IT guy to do?

Ian

RE: Can't uninstall Nortel Contivity VPN software.

I have the same problem.. except mine is much worse, when I try to install/uninstall the contivity client my system BSODs!!  I tried removing the files manually out of Program Files, and deleted the registry entires under HKL\services\current control set, and manually deleting the ipsecw2k.sys found in the .inf file.. yet still, I cannot reinstall the darn software without BSODing.  What is the darn install program doing that is causing this bsod?!?!

RE: Can't uninstall Nortel Contivity VPN software.

I have had the same issue, here is how I fixed it:
Use regedit to search for and delete the following entries:
ipsecshm
contivity
extranet
nortel

Some edits may need to be done in safe mode.

After a reboot you should be ok barring any other issues.

Steve

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close