×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Trying to get Win98 to install a modem properly

Trying to get Win98 to install a modem properly

Trying to get Win98 to install a modem properly

(OP)
I am trying to install a US Robotics 56K Modem (ISA) into my computer (Win 98). Win 98 seemingly detects the modem properly after the login screen, and installs the driver (from the CD). The installation seems to be smooth, just as one would expect a PnP device to behave.

However, as I went into Device Manager to check the installation, I found a yellow exclamation point next to the modem icon, indicating something is wrong. The error message is :

"the device is not working properly because the BIOS in the device is reporting the resources for the device incorrectly (code 9)."

The modem did not occupy any IRQ either.

I have tried going into safe mode to remove the driver and re-installing it. I have tried a different ISA slot. Each time, it ends up the same. I checked the Microsoft and the 3COM web sites to no avail. Has anyone else encounter this problem? Please advise, as I do not know what else to try. Thanks.

D. Chang
dkc@llsi.com

RE: Trying to get Win98 to install a modem properly

(OP)
What do you mean "manual"? If you are suggesting setting jumpers, there aren't any on the modem. I have since thought of going into the CMOS to see if there is a setting I can tweak, but I have not tried it yet.

RE: Trying to get Win98 to install a modem properly

(OP)
I went into the CMOS to disable serial port #2, which occupied irq 3. I also enabled the modem to use Irq 3 in the CMOS (I tried it by disabling this feature as well). It still did not work.

I also deleted all registry keys involving the modem and re-installing the modem.

I tried to select the modem myself and assigning it to COM2 (Jsauce, I think this is what you mean by "manual"). This did not work either.

Any advise? It would be nice to solve this mystery and learn a good lesson.

D. Chang
dkc@llsi.com

RE: Trying to get Win98 to install a modem properly

I would suggest that you check if the BIOS is set with a PNP Operating system and that it AUTO detects the if reources are ISA or PCI.. It worth a try I suppose...?!?!

RE: Trying to get Win98 to install a modem properly

-Reset configuration data in the bios, this should force computer to re-enumerate PNP devices
-during post the computer should give a device listing describing each of the PNP devices and the IRQ it's using, try to take note of the. The modem probably won't show up here cause it's ISA, but may give a clue as to resource allocation conflict?
-first boot into safe mode and blow away any modems and com ports and duplicates in device manager.
-Are you using a brand name computer with any integrated features such as a network card? If so, try disabling them.
-remove any other hardware in the computer, such as extra video cards, sound card, etc.
-since your modem is ISA, you may have to specify that in the BIOS, or reserve it's resources or specify it as a legacy device
-of course, maybe the modem really is misreporting itself, it could be defective - trade it in for an external, in my opinion they're much better

Let us know how it goes...


RE: Trying to get Win98 to install a modem properly

I agree go external. I've been using the USR/3COM Courier V. Everything External for a year and a half and it is by far the best modem I've ever used, wouldn't use anything else now.

John D. Saucier
jsauce@net1plus.com
Registry Backup

RE: Trying to get Win98 to install a modem properly

(OP)
Everyone,
The problem is resolved. I did a bunch of things, but what probably did the job was the disabling of both serial ports (I fruitlessly disabled serial port B) and resetting the whole configuration data in the BIOS (as suggested by Peelingk). After the reset, it took me a while to restore all the drivers (ran into problems), especially in "system devices" under Device Manager. I paid special attention to anything that referred to "ISA". After the modem was (finally) detected properly, I had to reactivate serial port A.

I totally agree that an external modem is better. However, I rather go with an internal modem because of its cheaper price and the fact that I don't have to find an extra electrical outlet for it.

I thank everyone for your input and support.

D. Chang
dkc@llsi.com

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close