×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

psql not responding to commands?

psql not responding to commands?

psql not responding to commands?

(OP)
I have a RH Linux 6.2 box running Apache and PostgreSQL.
My problem is as follows:
I am using php to talk to postgres to extract, update and remove data.And it all works great.I also have phppgadmin installed and that works as well.But I am unable to use the psql command at all.
I type in a command, and the linux shell interprets the request without error and gives me a blank line? (Waiting for more command line requests)
The postmaster is running.I stopped the postmaster and did a "ps -xf | grep post" and nothing appeared (except the ps command) - so the postmaster seems to be functioning properly without strange orphan children lying around.Also, as I said before... I can access the dBs through php and phppgadmin.
I haven't seen anything like this before...
Also, everything is installed in the default locations using the default settings (port 5432, postgres user etc...)
Any ideas would be appreciated

RE: psql not responding to commands?

did you use psql <database> ?
i'm using debian but have compiled postgres, php and apache from source and then installed manually - far better i think that relying on pre-built bit's and bobs in the distribution.

i'm abck at work on monday so either reply to this or mail me at work (sbrett@e-mis.com) if you still need help.

the only difference between what we use is the flavour of linux so we should be able to sort something out ...

RE: psql not responding to commands?

Check for your php. Did you compile php with Postgresq support  ( --with-pgsql=/DIR

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close