×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Tab controls with subforms - fill in ID number automatically

Tab controls with subforms - fill in ID number automatically

Tab controls with subforms - fill in ID number automatically

(OP)
I am probably missing something really simple here, but I have no idea what it might be. I have a data entry form that I created with tab controls that contain subforms.  Four tables are represented and three of the tables are linked to the main table by an autonumber field.  I know that the fields in the subforms have to be "number" fields to accept autonumber values.  Everything works fine when you are in the main table itself and you use the subdatasheet view, but when you try to enter new records from the form, you get an error message. How can I get Access to fill in the ID number on the subforms automatically?  
Ex: The main table is the Customer table which has an autonumber ID field. There are also tables for Demographic information, Comments, and Orders. How can I get that autonumber to sync up with the subforms?

RE: Tab controls with subforms - fill in ID number automatically

You need to go to the properties of the subform control.  Under the data tab, you need to set your link master field and link child field to the two autonumber fields of the two tables.

Mike Rohde
rohdem@marshallengines.com

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close