×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Installation Failure?

Installation Failure?

Installation Failure?

(OP)
Hi, I am new to Visual Sourcesafe, installed the server componenets onto the server - message says run ddupd.exe.
Created a folder - E:\vss\ - ok
Ran mkss.exe e:\vss\ - ok
Ran ddupd.exe - message says "um.dat may be corrupt"
I've tried login in, but get a message saying " Sourcesafe database on c:\it\vss_admin does not exist"

I am VERY confused - can anyone get me through this?

Thank you in advance...

RE: Installation Failure?

We have similar problems. Only we had the problem that sourcesafe translates driveletters to UNC paths and then does not understand UNC paths.

So we hacked the registry.
in the key:
HKEY_LOCAL_MACHINE\Software\Microsoft\SourceSafe\Databases
set the value
VSSafe = E:\somedir

Where somedir is the directory that contains the sourcesafe.ini file and all the nice subdirectories. You may have to look for similar HKEY_CURRENT_USER entries as well, depending on your OS.

Good luck

RE: Installation Failure?

(OP)
OK changed the registry - nothing happened!!!

Started again with the command:
mkss E:\vss\ - ok
E:\vss\ has 5 items in it now:
1.Folder called Loggedin
2.File called aaaaaaaa
3.File called aaaaaaaa.a
4.File called aaaaaaaa.cnt
5.File called um.dat

I had a look at the srcsafe.ini and ss.ini files.
Changed srcsafe.ini file to look for data at E:\vss\

Now when I startup Sourcesafe admin, I don't get "Sourcesafe database on c:\it\vss_admin does not exist", i get a "um.dat may be corrupt"
I am then asked to find the location of the srcsafe.ini file.

To correct this I ran analyze -F e:\vss\ from the command prompt and get a "version.dat" is missing message.

I assume that there should be more than the 5 items in the E:\vss\ folder that was created by running mkss.exe.

I hope this gives more info. and you are able to help me further with this problem.

Thank you in advance,

Shaun

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close