×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

ORBIX E2A related problem .... very basic.

ORBIX E2A related problem .... very basic.

ORBIX E2A related problem .... very basic.

(OP)
Hi,

I have to work on ORBIX 2000. I am trying to work with some simple programs to test the interoperability. While doing so, got struck in the middle.

Enviroinment: ORBIX E2A standard edition on Windows NT. Using Visual C++ for compiling.

Scenario: I have configured a local domain. Created an IDL script and built server and client executables with the help of VC++. This works fine and as desired.

Problem: I configured a domain and stored in a configuration repository which can be accessed thru specific port. Now I wish to run the server on one machine and to query the server from different machine thru configuration repository.While starting the server(executing server.exe) it gives me the following error...
/*
C:\OCGT\HelloExample\server\Debug>server.exe
Initializing the ORB
Mon, 17 Jun 2002 09:40:14.0000000 [CHNSHL13772:1452] (IT_CORE:300) E - client_binding_list config variable not found
Unexpected CORBA exception: IDL:omg.org/CORBA/INITIALIZE:1.0: minor = 0x49540105
 (IT_Core:NO_CLIENT_BINDING_LIST), completion status = NO */

What can be done? Do I need to modify any configuration parameters? I feel that Iam missing something basic, but couldn't find where? Please advise.

Thanks in advance,
Mahesh

RE: ORBIX E2A related problem .... very basic.

Hi Mahesh.,

 When you had cread your domain say xxx., i assume you had used the configure script that is part of the Orbix 2000 1.2.1 kit.,

  This might have created a configuration file with the name xxx.cfg plus start, stop etc., script files., in the configuration file do you see any lines having the name client_binding_list., it seems to be missing.,

else rerun the configure script for the domain and see whether the client_binding_list is getting created in the configuration file.,

Regds
Muthu

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close