×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

unicode mfc application using rich textbox under windows 98/ME

unicode mfc application using rich textbox under windows 98/ME

unicode mfc application using rich textbox under windows 98/ME

(OP)
hi,
i have a unicode MFC application that I wish to run on Windows 9x/Me.
for that purpose I linked with unicows.lib before linking to any other
libray.
however and since I'm using MFC as a shared dll I had to rebuild the
CRT and MFC libraries.

/nod:kernel32.lib /nod:advapi32.lib /nod:user32.lib /nod:gdi32.lib
/nod:shell32.lib /nod:comdlg32.lib /nod:version.lib /nod:mpr.lib
/nod:rasapi32.lib /nod:winmm.lib /nod:winspool.lib /nod:vfw32.lib
/nod:secur32.lib /nod:oleacc.lib /nod:oledlg.lib /nod:sensapi.lib
unicows.lib
kernel32.lib advapi32.lib user32.lib gdi32.lib shell32.lib
comdlg32.lib
version.lib mpr.lib rasapi32.lib winmm.lib winspool.lib vfw32.lib
secur32.lib oleacc.lib oledlg.lib sensapi.lib


All this done, I was able to run my application on windows 98.
But my problem is in one control I'm using : the rich textbox
(Richtx.ocx)
to place and retrive unicode text from that control I'm using the
SendMessage
EM_SETTEXT and EM_GETTEXT with cogepage 1200. (these supposedly use
the RichEd20.dll. (I have the dll for the RichEdit 3.0.))
but none of these is working properly on win98
Besides I noticed that the control sends an OnChange notification as
soon as the dialog that contains it is created.

does anyone have any idea on what might be causing it or how can I get
aroud it

any help would be greatly apreciated

thx

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close