Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

xolehlp.dll file

xolehlp.dll file

xolehlp.dll file

I am running Sidekick 99, release 6.01 under Win 98, Rel. 2.  Norton Systemworks keeps reporting that file "xolehlp.dll" (which I assume is some type of help file) is missing.  I have reinstalled Sidekick 99 and "xolehelp.dll" still does not load.  

Does anyone know what that file really does and how (or do I really need to) make it available when I run Sidekick 99?

Thank you.

Thomas H. Downey

RE: xolehlp.dll file

Dear ThomasHDowney,

xolehlp.dll is a file whose Product Name is:

Microsoft Distributed Transaction Coordinator

So the problem is more than likely with Windows98 and not with Sidekick99, have you tried to extract it from C:\Windows\Options\Cabs
or the Windows Installation CD.
You should copy it to C:\Windows\System.

But the easiest way would be to run System File Checker
Go to Start|Run| and then type in SFC and press Return.
click on
Extract one file from Installation Disk
Then copy and paste xolehelp.dll
into the text box and press return/enter
you may have to point it to the installation location.


Regards Jim

RE: xolehlp.dll file

Dear Jim:

  Thanks for your input.  

  Unfortunately, I have not been able to locate the "xolehelp.dll" on my Win 98 Rel. 2 disk.  When I looked at MicroSoft's website, it appeared to indicate that the file was used only with NT.  

  It may be that the download file for SideKick 99 Rel. 6.01 on Starfish Software's abandoned products site was intented for installation on NT systems (as well as other MicroSoft operating systems).


RE: xolehlp.dll file

Dear Tom,
Admittedly on my system (which for reasons best known to myself is on 98 release 1) the file is present.
I can't say for certain but in the event that only Norton says it is not there and it is not referenced by anything else you can ignore it...

If you comment on one of my FAQ's in this forum I will get the email address you gave Tek-Tips when you signed up and I could send it to you together with the location it is in, (from my workplace that has Win98 release 2).

Regards Jim

RE: xolehlp.dll file

I was directed from a helpful guy in the Packard Bell forum to this thread.  I am experiencing the same problem with xolehlp.dll Could I please have the file and location emailed to me.  You will save me PC from being thrown in the bin many thanks - ntertransukltd@hotmail.com

RE: xolehlp.dll file

I was directed from a helpful guy in the Packard Bell forum to this thread.  I am experiencing the same problem with xolehlp.dll Could I please have the file and location emailed to me.  You will save me PC from being thrown in the bin many thanks - intertransukltd@hotmail.com

RE: xolehlp.dll file

Dear Vas69,
I have emailed it to the above address but just in case here is the address of a site you can download it from:

There is also an explanation of the reason for this error message and a description at the site:

Forum: sybase.public.ase.nt
Thread: DTC Operation Cannot load XOLEHLP.DLL

receiving the following in error log: The DTC Operation Cannot load XOLEHLP.DLL - - failed with
error (0x0) MSDTC Initialization failed

Below is the answer received

Bug Number: CR# 211870.

Title : Cannot initialize MSDTC: cannot load xolehlp.dll


The xolehlp.dll is a Microsoft .dll file which belongs to The product MSDTM.
The MSDTC connection is attempted by the kernel even with "enable DTM" = 0, because we have to
initialize the environment very early in the kernel even before parameters are analyzed. If we are
unable to initialize the DTC environment we will always display this information at startup in the
log. It can safely be ignored.

This message is because the service MSDTC has not been installed in your NT system. If you are not
using DTM this message is not important.

Jim Egan [TeamSybase] Senior Consultant Sybase Professional Services

End of Answer

As described above, this error message is not a bug originating with Sidekick or Starfish AFAIK(Thank goodness)


Regards Jim

RE: xolehlp.dll file

Many thanks

RE: xolehlp.dll file

Same issue.  I have followed your instructions, but cannot find the XOLEHELP.DLL on my win98 disk.  Could you please send it to me also?

Keith Housholder

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close