×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Error registering COM+ Application :(-

Error registering COM+ Application :(-

Error registering COM+ Application :(-

(OP)
During development, I installed COM+ proxy on a client W2K m/c. It was working fine untill I install new version of .MSI for new version of DLL(with new IIDs) now I am getting following error

"Error registering COM+ Application. Contact your support personnel for more information"

I tried to act a little smart and manually cleaned the registry thinking this will fix it but i think now I am way too messed up. Can any Guru help please? this is my own dll package and I am not using Crystal report 8.

PLEASE!!  help me ...................god.

RE: Error registering COM+ Application :(-

Dear
well yes you have messed up with your client registry but there is a way to install MSI again please
Settings>ControlPanel>Add Remove Program
and see for you "Application Proxy" just remove it from there,if you are not being able to remove it from there then there still a solution just make a new MSI from MTS SERVER and installed this new MSI on the client ,usually the New MSI will be overwritten to the OLD ONE ...
I hope this will help you out
Regards
Nouman

RE: Error registering COM+ Application :(-

(OP)
Thanks

I fixed it. Another issue, Is there anyway I can get an image file from COM+ server at client in VB6? How do i serialize image files in vb? I do not want to use XML.

IS there any quick solution.


RE: Error registering COM+ Application :(-

Dear Friends
well i think the solution of ur prob could be done in several ways..now u want to send "Image File" from client to Server well there could be two solutions to it
1) Just sent the "Image Files" in chunks (portion) in the recordset if its a very big file (if u don't know how to sent the files in chunks then let me know i will provide u the code ) But still it have to cross the Server to client and marshall across the bounderies so although bit fast but a costly sloution
2) the second one is to make a string for Picture URL and just send the URL to the client and then load the picture from that URL ,i usually use this to open the picture ,its fastest and the best solution to me..
okay i hope u got it
If you have any q please feel free to contact me
Regards
Nouman

RE: Error registering COM+ Application :(-

My problem is with installing a COM+ Application proxy on a Windows2000 Professional client.  It doesn't matter if the proxy was created on Win2000 server or professional.  Windows installer always give the error message - Error Registering COM+ Application.  Contact your support personnel for more information.

Please help

RE: Error registering COM+ Application :(-

(OP)
hi,
i m first time using MTS server, so plz guide me how to start

RE: Error registering COM+ Application :(-

dear sal2000
the problem u r facing is that the COM+ component is already installed on that Win2k or Server machine,so its conflicting with the client installtion what u have to do is to unregister these from ur client machines
a) if u have previously installed these components on the machine using clinet proxy then u can remove it from ADD-REMOVE Program in control panel
b) If u registed prev registerd component on the machines using COM+ Adminstration by making Package and the installing these componets in that pacakge then remove that package from there and then run the Application Proxy for client
i hope u got it
if u still have some qs u can let me know
regards
nouman

RE: Error registering COM+ Application :(-

(OP)
I created a VB COM+ DLL (3 actually), successfully installed it on one client machine (the application that is) and then exported the COM+ package from this XP box.  I took the client proxy package install and tried running it on a 2000 Server (also Domain Controller) for the FIRST time and I get this error.  Is there something that needs to be installed??

RE: Error registering COM+ Application :(-

Do you guys have .Net (CLR or Everything) intalled on your box. I have .Net on all my 3 boxes and the other boxes I tested has it too. I doubt COMTI. Xp has a property you can choose which kind of fixes this problem. If we can find out how to support backward compatibility to COM+ 1.0 , will fix it.

Let me know if anyone has clues.

Aj

RE: Error registering COM+ Application :(-

Hi,
while running .msi on Client machine(2000 Pro) it runs without giving any error(earlier it's giving error so i uninstalled it using add/remove program and also had removed all the registry entries for the same) . Now problem is that though it's not giving any error still it's not copying/registering the dll to client machine because programfiles\complus application folder creates a empty folder with the the name as of classid of the dll but it contains nothing..and generates the obvious error when tried to run the client program using the same dll.
what should i do to overcome this.....Pls. suggest...
Thanx,
Jyoti.

RE: Error registering COM+ Application :(-

COM+ GIL (Visitor) JUN 11, 2003
During development, I installed COM+ proxy on a client W2K m/c. It was working fine untill I install new version of .MSI for new version of DLL(with new IIDs) now I am getting following error

"Error registering COM+ Application. Contact your support personnel for more information"

I tried to act a little smart and manually cleaned the registry thinking this will fix it but i think now I am way too messed up. Can any Guru help please? this is my own dll package and I am not using Crystal report 8.

PLEASE!!  help me ...................god.

sysfoxfap@hotmail.com       ......... thanks
 

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close