×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Probably simple answer but....

Probably simple answer but....

Probably simple answer but....

(OP)

  I want to test a Perl Script on NT Server. How can I run the script through the browser. Basically, After I have installed Active Perl on my system , it paths out correctly through perl.exe. How can I test the script on my browser. I have NT's IIS running so I have a HTML server running. As well I have tested it on Analog X's with no avail. What happens is I try to run the script and the Command box opens up on the screen and displays some information very quickly and then closes. Now how may I see the script , or any script through the browser properly as you would from a web site???  

                                 Thanks in Advance,
  
                                              John Stephens

RE: Probably simple answer but....

Have you tried placing the script in the cgi-bin directory (or wherever you can execute CGI scripts) and then opening up your browser and typing in the domain and path in the location box?

I'm not familiar with your particular setup (NT/IIS), so there may be configuration issues specific to your platform/webserver that need to be resolved as well.

Regards,

Russ
bobbitts@hotmail.com
Bobbitt is in

RE: Probably simple answer but....

I would suggest using Apache. It is much better than IIS.

-Vic

vic cherubini
malice365@hotmail.com
epic software
====
Knows: Perl, HTML, JavScript, C/C++, PHP, Flash, Director
Wants to Know: Java, Cold Fusion, Tcl/TK
====

RE: Probably simple answer but....

(OP)
I am using IIS 4.0, When I run the script from the command box it runs and sets up the folders in my base directory so I know the script is running and Perl is pathed correctly.
When I url it through LocalHost it will try to open the file as if it were Downloading it. A box will ask me to specify a location for the file. If I instruct it to open it from its current location it will open the Commandbox and run it through there. I can see the <HTML> etc. As well it opens the folders correctly. It just won't run any script through the browser normally.

As for my Perl location I have it in the script as follows:

#!D:/Perl/Bin/Perl

I have checked permissions etc and they are all set.. It is probably something simple I am forgetting. And NT does recognize the PL extention and knows where to find the path or it would not open the Command Box instead of running through the Browser.

Any Help would be Appreciated

John

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close