×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

can't modify or run a form

can't modify or run a form

can't modify or run a form

(OP)
hello

Yesterday i sent you my question but not as a member, so i want to repeat my question again for further help.

I had a form running with no problem, but when i modify the form and change the properties of a date field, as i wrongly wrote at the format properties the word of 'date',
i closed the form and tried to test it but no way to run it or correct what i've done, always give me error no. 2005 and return me to the command entry.

Please if you can help because this form took a lot of work and it consists of 4 pages of pageframe with a lot of data.
    
I'm waiting for your response asap.

Best Regards,
suha

RE: can't modify or run a form

Well, everybody in this forum is willing to help everybody regardless if you're a member or not :-).
Regarding your problem, I don't know error #2005. I'm using VFP3 only. What's yours?
Can you give the details of that error message?

RE: can't modify or run a form

(OP)
thanks for your attention
I'm using vfp6 and the error message is:'Error loading file-record number 5.<or one of its members>. Parent class name is invalid.'
And i click the help button of this message it's as follow:

"Error with " name " - " property ": " error "  (Error 2005)
 You have attempted to set a property to an illegal value  through the language. "
  

 

RE: can't modify or run a form

Did you move or delete class libraries?  If so, put them back and see if that fixes it.  If not, it looks like you might have to hack the form file:

* first, back up the subject form

use MyForm.scx
goto 5
browse


Now look at the Class and Classloc Memo fields for record 5 (should be the current record).  Are the values in these two fields proper?  IOW, does the Class shown there actually exist in the class library specified in Classloc?

If not, then you'll need to reset these to the defaults.  I believe you need to completely blank out the Classloc (CTRL+A, [DEL]), and set the Class to the appropriate base class for that type of object (you can look in Baseclass and Objname to determine what this thing is).

Robert Bradley

FoxDev - Visual FoxPro Development

RE: can't modify or run a form

Actually, the form itself is a table with extension .SCX.  If you really can't fix it, I woul suggest you try opening it as a table using the USE command, the field name are quite self explanatory though most of them are memo fields.  The format field that you set incorrectly i think is stored in the field property.  Just locate the proper record (if you still remember the object name, the locate it using the objname field).  Of course, ou would want to make a backup of your form before you do this.  Remeber to close the table before you run the form again.  HTH.

RE: can't modify or run a form

(OP)
thanks for your help, i tried what you told me to do ,it
didn't work, but i appreciate this new information for the next time i will know what to do from the beginning.

maybe the form itself is corrupted as i tried to open 'myform.sct' by modi comm myform.sct and corrected the error i thought it caused the problem.


suha

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close