×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Virtual Join Error!

Virtual Join Error!

Virtual Join Error!

(OP)
Hi

In my apm.quick format, I get the following error everytime the form opens:

"virtual join cannot find link field (display,show.rio)"

Does this mean I've added a value to my link file and SC does not know what field it's supposed to be joining?

Any suggestions most welcome

birklea ~©¿©~ <><
I know what I know...don't presume that I know what I don't! Smithism!!!

RE: Virtual Join Error!

It means that you that you have a virtual join subform on the format that doesn't have an entry in the link record.

RE: Virtual Join Error!

(OP)
so to fix the problem:

1) Create a reference for the VJ on my subform into the linkfile

or

2) Remove the subform

What would you suggest?

birklea ~©¿©~ <><
I know what I know...don't presume that I know what I don't! Smithism!!!

RE: Virtual Join Error!

Yep, those are your two options, which one you choose depends on whether you need the subform or not.  Best way to figure out which subform is missing is to open two sessions, one with a ticket open, one with forms designer open, then check the tabs for subforms and see which ones don't appear when looking at a ticket.  If the link is missing, the fields in the subform just won't show up.

RE: Virtual Join Error!

(OP)
Thanks chrishaw.

I removed the redundant subform....drat...it'll probably be needed in the future.

Anyway...no more virtual join error!

thanks

birklea

birklea ~©¿©~ <><
I know what I know...don't presume that I know what I don't! Smithism!!!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close