×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Using OLD version of REBUILD.EXE with BTRIEVE files

Using OLD version of REBUILD.EXE with BTRIEVE files

Using OLD version of REBUILD.EXE with BTRIEVE files

(OP)
We are "suddenly" unable to use REBUILD to re-index the data files in our accounting application.  The app is character-based, & uses the Btrieve engine on our NetWare 3.2 server.  We have re-indexed files in the past, but now we can't get past the error shown below.  The command is run in a DOS window on a W98 PC after the Btrieve requestor is launched (REBUILD.EXE & data files all in root DIR):
C:\REBUILD ACCT.DAT,TEMP.DAT /V /S:BTRV /T:BTRV
results in
***Error on input file - file not found
I've tried using the full path in the file name, upper case, lower case, disabling background programs like AV & CD utilies.  The Micro Focus REBUILD.EXE version is 3.1.31.  I've even restored another copy of the utility file from an old tape & it behaved tha same, so don't think it's corrupted.  The maker of the accounting program no longer supports Btrieve, so they're no help.  While our accounting data is fine now, if a data file goes bad, we'll be in trouble.  I realize all this stuff is terribly old, but it did work fine -- something broke, or we forgot how to use it correctly.  Any ideas?  Have posted this in the Micro Focus forum as well.  Thanks,
Jim

RE: Using OLD version of REBUILD.EXE with BTRIEVE files

I'm sure you've tried it but it wasn't clear from you message.  Does this command work:
C:\REBUILD ACCT.DAT /V /S:BTRV /T:BTRV

ANother option is BUTIL instead of BREBUILD.  TO use BUTIL, try:
BUTIL -CLONE <newfile> <oldfile> /O<ownername>
and
BUTIL -COPY <oldfile> <newfile> /O<owner1> /O<owner2>

There is also a BREBUILD and BUTIL NLM that would run on the NetWare server itself that uses the same options and syntax.

mirtheil@mirtheil.com
Custom VB and Btrieve development.
Certified Pervasive Developer
Certified Pervasive Technician

RE: Using OLD version of REBUILD.EXE with BTRIEVE files

(OP)
If the /T switch is used, then the command returns an error if a target file (like temp.dat) is not specified.
Don't know what else to try with this utility.
So, will try the others you mentioned.  Thanks,
Jim  

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close