×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Invalid DOS path

Invalid DOS path

Invalid DOS path

(OP)
When I install Sourcesafe 6 on a machine at our office, it cannot find the central database. To be more precise: you can browse to the file, select it, and see that is is converted to a UNC path (so S:\<some dirs>\srcsafe.ini is converted to \\<servername>\<some dirs>\srcsafe.ini). Next, I receive an error message saying that this UNC file cannot be found. When I hack the registry and manually set the default database path to the non-UNC path, sourcesafe starts up with a message 'invalid DOS path'. Is there a way to overcome this bug?

Best regards,
Willem Bogaerts

RE: Invalid DOS path

I've encountered the same problem two different ways, so the way you start up SourceSafe needs to be known.  However, here's the "fixes" depending on your setup:

1) If you start SourceSafe from the command line, you need to create an environment variable (system type, not user) called ssdir and give it the UNC path as the value.

2) If you start SourceSafe via the GUI, you need to specify the UNC path in the srcsafe.ini file where you installed your client.  There's a header in that file telling you that you should have a single #include \\<servername>\<somedirs>\srcsafe.ini.

I'm guessing your doing method 2.  Note that if you access more than 1 SourceSafe database, there is still the tendency to get that message.  My fix for that is to change the #include to the path of the other database's srcsafe.ini file and restart the GUI.  Why this #include is there, I have no idea since it seems to limit you access to one database at a time, though in practice I've found that to not be true.  It just needs to be set to one in order for things to work.

Good luck.

RE: Invalid DOS path

(OP)
I start sourcesafe via the GUI. However, I want sourcesafe to connect with the shared database by default. So I have set the default database to the database on the server. And that is the thing that does not work. I can select the shared database from a file-open dialog (via drive-letters, even when I enter the complete filename 'S:\...\srcsafe.ini' in the enter filename textbox!), but when I click OK, I get the message that that the path (which is converted to UNC by sourcesafe itself) is an invalid DOS path. On my system, hacking the registry helped:

[HKEY_LOCAL_MACHINE\Software\Microsoft\SourceSafe\Databases]
"srcsafe.ini"="s:\\shared\\oase\\VSSafe"

It used to show the UNC path and I changed it back to the drive-letter path. However, on an other machine, this registry key is also messed up when sourcesafe starts. On that machine, sourcesafe starts, complains that \\NEELIX\SHARED\OASE\VSSsafe\srcsafe.ini is an invalid DOS path en sets the registry key to that same path it just claimed to be invalid. This effectively means that the shared database cannot be selected at all.

Best Regards,
Willem Bogaerts

RE: Invalid DOS path

(OP)
I had the same problem with a new installation of VSS 6.0c on Windows 0. The problem was corrected by hacking the registry in BOTH the "current user" and the "local machine" root keys. I had to change the UNC paths back to Drive-letter paths.

RE: Invalid DOS path

I added the #include statement that looks like:

#include \\<server name>\other dirs...\srcsafe.ini

And this did not correct my problem.  I receive the same error invalid dos path.

RE: Invalid DOS path


I have modified the registry changing the UNC paths to drive letters with no results.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close