×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

How to start a webbrowser with URL from field in database?

How to start a webbrowser with URL from field in database?

How to start a webbrowser with URL from field in database?

(OP)
Approach 9.5 comes with a smartmaster called "Internet World Wide Web sites" In the database are 500 records. One can add and edit the records. But what is interesting to me is the possibillity to execute the standard webbrowser with the URL from the field. So next to the field http:// filled with for example www.warnerbross.com there is a button. When you click on it the webbrowser is starting up with warnerbross.com in the URL.

I tried to figure out how to apply that in my databases but it is not as simple as adding a hyperlink in a HTML-document...

Can anyone give me a clue how this is accomplished?

Is it possible to do it without extensive study in script-programming?

Thank you for your attention.

RE: How to start a webbrowser with URL from field in database?

Easy as pie!

1-Create a macro. The only command used is Open. In the File Name box type <<tablename.fieldname>>, making sure your field is enclosed by two leading "<" and two trailing ">". (you need to use the tablename.fieldname syntax even if you only have a single dbf w/ no joins!)

2-Attach the macro to a button.

Done

This method does assume that you have a default browser that is registered propperly.

RE: How to start a webbrowser with URL from field in database?

(OP)
This was the solution I needed. Thank you very much.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close