×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

My AD64 voicemail crashed

My AD64 voicemail crashed

My AD64 voicemail crashed

(OP)
This thing was installed about 7 years ago and have been running fine. Yesterday, I needed to stop the Voicemail service to change the config on the serial port. I did this as we have a Hotel PMS and I'm trying to make it talk to the voicemail system. In the last week, I've stopped and started the voicemail about 20 times with no issues. But this time, when I clicked on Start, it wouldn't start. I waited like 30 minutes. Then rebooted the server, but it still wouldn't start. In fact, when I opened the control console (the one that shows with a traffic light if it's running), it said the Voicemail is not even intalled.
I looked with a collegue for errors in Event Viewer, and it complained about some c-tree errors on some files. Anyways, I wasn't sure what to do with that. At that point I created an off-line backup, which came out to be about 7GB file. I also had an on-line backup done about a month ago, which was 8GB at that time. I ran Windows Scandisk which found no issues with the HDD.
So I did a fresh install (newly formatted a new HDD and installed Win Server 2003 R2, and then a clean fresh install of the voicemail).
It works and it answers but nobody has voicemail box and messages. So now I'm trying to recover those.

So I do an Restore from the 1 month old backup. Restore takes about 1.5 hours but compltes just fine. Trying to start the Voicemail, and after about 45 minutes of "Starting" it stops. Not a good sign.

Found an earlier post on a similar subject so I tried the below from that post:
1) copy *.avd files from c:\vmail to a temp folder, and then delete all *.avk files from the c:\vmail folder.
2) In Command Prompt I say "voiceserver dbchk /f"
3) It runs for about 1 hour and it ends with saying there is a problem with avdial.avd file. I re-ran the same command and again, after 1hr, it stopped with the same error. I'm re-running that command again, the 3rd time as that's what that other post said.

This is where I stand today. But I'm not sure what steps I'm going to do after this. Most likely I'll just try to start the service, and if needed, reboot and start the service.

But does anyone have a good idea here? I don't feel like re-creating about 2,000 VM boxes as even with the range-create, it will take days. Then I have to tell all the users to re-record their names and greetings. It's just massive.

So I can do a nice clean, fresh intall, and I have, at my disposal, a 1 month old on-line backup file that was done where there was no sign of problem yet.

RE: My AD64 voicemail crashed

(OP)
After doing the 3rd dbchk, it found no more error. I was also able to START the voicemail (fired up within about 30 econds). Then I was able to dial into my vm box, and it accepted my passcode, so it is using the backed up database.

However, on the server, when I opened to admin console for the voicemail, it listed no vm boxes. Not even mine that I just dialed into.

I'm doing an on-line backup and then a restore, to see if that makes things better.

RE: My AD64 voicemail crashed

(OP)
Backup and restore didn't make a difference. I can start the service, it's running, answering calls, taking messages like it used to. But the management console is unable to list the existing mailboxes. It allows me to create new ones, and those I just create are listed. When I try to create one that I already know exists (but not listed), I get an error that it already exists.

So it's very crippled right now.

Windows Event Viewer shows errors like:

- LoadSubscriber: Entity Not an Owne. HRec = <0x3ce600>, cc=0
- Error Listing Subscribers. Hrec = <0x3ce600), cc=3
- DBL_RecordRead: c-tree error 30 (dm exceeds logical end of file) from ReadData

RE: My AD64 voicemail crashed

(OP)
I'm still open for suggestions. I've reinstalled windows and then the voicemail all from scratch and re-created about 300 voicemail boxes from csv file. Informed the users to re-set up their boxes.

This is working fine, but in the control window where there is this traffic light with red,yellow and green light, it shows yellow (Starting). It never turns green.

Otherwise the functions appear to all work fine.

But still I want to reolve the yellow light, and also looking for the last upgrade patch that was issued for this.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close