×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

User Portal - Bug regarding hang up call?
2

User Portal - Bug regarding hang up call?

User Portal - Bug regarding hang up call?

(OP)
Testing a new IPO SE 11.1.2.4 and User Portal seems OK.
Installed Media Manager on the same server since I'm not sure recordings arent accessible if using a App server..

Now you have a little tab showing the active call even if you are on another page than the Dashboard/Home page.
On an incoming call You can answer or skip the call.
+ You can mute the microphone from this tab.
- You can't hang up the call from the tab, you need to go to the Dashboard page to do it. You can live with this.

More irritating is the fact that if the other part of the call hang up before you,
there will be 20 seconds of busy tones and you have to wait this out.
- A workaround would be to make another call, perhaps to a silent flow in Voicemail pro, and then quickly hang up.
Anyone else who have a better solution?

RE: User Portal - Bug regarding hang up call?

Is that all calls, just external calls, what trunk types? Details may help us help.

Stuck in a never ending cycle of file copying.

RE: User Portal - Bug regarding hang up call?

(OP)
I really think the issue is the User Portal itself.
  • Same issue with internal calls as with external calls.
  • No difference if the User Portal extension is the caller or the receiver of the call.
  • Tried User Portal as Softphone on Chrome, Edge and Firefox - all browsers up to date.
  • Tried internal calls to and from SIP J100 phones and 3rd party phones.
  • The external calls via SIP trunk which works perfectly.
When the other caller hangs up, on the Dashboard page, the call window with the in-call functions disappear - as it should.
But there is an annoying busy tone for some 15-20 seconds before it ends and the User Portal hangs up by itself.

If you have another page open while this happens, be it Call History, Voicemail, Recordings or settings,
That little tab showing an ongoing call is still there, but there are no button to hang up, only that Mute button.
- -

My "workaround" - Until Avaya have a fix to automatically disconnect, like any other softphone does.
  • Created a Short Code to a simple silent loop module in VMPro.
  • Added Shortcode in Personal Contacts and Favorited.
  • When the other part hangs up, go to Dashboard page, Click favorite. Then click hang up when call controls show..
- -

RE: User Portal - Bug regarding hang up call?

Unless it is a bug, the only setting that might be in play is System | Telephony | Tones & Music | Disconnect Tone. But that should affect all IP and digital extensions, not just user portal.

In some countries IP Office default is to play disconnect tone rather than immediately hanging up when a far-end disconnect is detected. Presumably, either local approvals requirement or simply historic preference in those countries.

You could try adjusting that setting to see what effect it has, but be aware it requires an IP Office service reboot (pretty quick on an Server Edition but still annoying to anyone with calls in progress).

Stuck in a never ending cycle of file copying.

RE: User Portal - Bug regarding hang up call?

(OP)
System | Telephony | Tones & Music | Disconnect Tone was on "Default"
Workplace softphone was working as desired, auto hung up. So I did not check Disconnect tone setting.

So I changed the Disconnect tone to "Off" and restarted.
Then I checked the setting and it was on "Default" again.
- So the setting is "invisible" but now User Portal hangs up correctly. Thanks again sizbut!

So it is depending on system locale. What an uneccesary setting!
Damn! This is the second time I encountered this issue, last time it was the J100 phones..




RE: User Portal - Bug regarding hang up call?

"What an uneccesary setting!" - In order to sell telephony equipment in each country, manufacturers have to comply with local requirements. And many of those requirements stem from the way analog telephone systems used to work in those countries. The requirements may have changed a lot now, but IP Office has very old roots, so be glad its original developers also provided a workaround.

Still, sounds like something got hinky in your system's configuration and was fixed by changing the setting (classic tech 101 - switch it off and on again).

BTW: What locale are you in?

Stuck in a never ending cycle of file copying.

RE: User Portal - Bug regarding hang up call?

I'm going to guess Stockholm, Sweden :)

RE: User Portal - Bug regarding hang up call?

(OP)
Yep it's locale Sweden.

Another thing I also have to fiddle with in new installations is the Dial delay count and Timout and short codes - to be able dial a full number befor the IPO fires away and send to trunk.
With Enbloc-Dialing we do not need to think about it - But it is set off this locale and the only way to set it is from the physical phones menu..

To have the Enbloc-dialling accessible in Manager/Web Manager would be nice, because it is a fixed setting in the locales.

My workaround is a bulk change (which always works well but probably not recommended) to set Enbloc-dialing on all users is to:
  • Export config as CSV
  • Open file in Notepad
  • Cut away all text except for the segment from User_Info_Start to User_Info_End. (Yes, it works importing a single part of config)
  • Change all ; -characters to § (which is not used at all in configuration, but semicolon may split up wrongly in Excel)
  • Save the file, Open in Excel.
  • In Excel: Select Column A, Select menu Data > Text-to-Columns.
  • in the Wizard: Delimited by Comma, Mark all columns in Datapreview and select Text. Finish
  • Now the users are split inte columns in Excel.
  • Search US_ENBLOC_DIAL / goto column FB. Select the whole column.
  • Change all "False" to "True" - Ensure the case! Should be True not TRUE
  • Save the file, overwrite. Close Excel.
  • Open file in Notepad again
  • Remove all commas after User_Info_Start and User_Info_End
  • Change all § -characters back to ; (Semicolons may be used in short codes)
  • Save the file. Import back to IP Office with Manager app.
When you get used to handle config with Excel you will find it a good way to bulk fix mistakes and anomalies in the config like wrong UserRights, quickly find and fix problems with users having set DND by mistake, wrong format on forward numbers, users with same mobility number etc..

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close