×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Website will load using hostname but not IP address

Website will load using hostname but not IP address

Website will load using hostname but not IP address

(OP)
I have an IIS site being hosted on a Windows 10 21H2 box (vendor supplied) that cannot load the site using the IP address, but it loads just fine with the hostname. I'm not sure when this started to happen, but it was just reported on Friday. No updates or changes have been made. I think it's related to the SSL configuration in IIS Manager but not entirely sure. I'm researching before making any changes. This system supplies content for an on-air television broadcast. The host name resolves. DNS is working. Any ideas, thoughts, or suggestions would be greatly appreciated.

Domenick Pellegrini




RE: Website will load using hostname but not IP address

What is the error that it is throwing? That should tell you if it's SSL... and did you try https://1.2.3.4 (obviously replacing 1.2.3.4 with the ip address)

It's strange, because the hostname would resolve to an IP address, but it could very well be an IIS or SSL configuration issue.

Just my $.02

"What the captain doesn't realize is that we've secretly replaced his Dilithium Crystals with new Folger's Crystals."

--Greg

RE: Website will load using hostname but not IP address

(OP)
I'm guessing it is an SSL issue. In IIS Manager, SSL Settings, Client Certificates is set to Ignore. I haven't changed this setting, but I suspect it will fix the issue. When I try it, I'll post the results.

Domenick Pellegrini




RE: Website will load using hostname but not IP address

If this query is not solved, One possibility is that the web server hosting the website is configured to respond to requests based on the hostname. The server may not recognize the request when accessing the site via the IP address, leading to a failure. Additionally, if the website relies on virtual hosting, where multiple websites share the same IP address, accessing the IP directly may not route to the intended website. This behavior is common when server configurations are optimized for virtual hosting based on hostnames rather than IP addresses.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close