×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

onstat -g ses returns "Changing data structure forced command termination"

onstat -g ses returns "Changing data structure forced command termination"

onstat -g ses returns "Changing data structure forced command termination"

(OP)
Hello,

I installed a new informix server version IBM Informix Dynamic Server Version 14.10.FC9 running on a RedHat Enterprise Linux 8.4 VM machine.
I noticed that every time i run the command

CODE --> informix

onstat -g ses <sessionid> 
i receive the following message:
Changing data structure forced command termination

On informix log file i do not see any error or warning at the time that i execute the command.
Note also that other commands eg.

CODE --> informix

onstat -g ath, onstat -g ckp, onstat -g dis 
, etc. are displaying the expected output.
I only face this issue specifically with

CODE --> informix

onstat -g ses 
command.
I found some old articles about this issue and they are mentioning a bug in informix if the client host which connects to the informix server has more than 8 characters in its hostname.
I tested the above but the issue remains.
Other suggestions mentioned that this output is displayed momentarily and if you try to run the command again the session information will be displayed but i tried to run the command repeatedly and i always get the same message.

Is it a known bug on version 14.10? Is there any workaround or do i need to fix something in my onconfig file.
If it is required i can post my onconfig file as well.

Please advise.

RE: onstat -g ses returns "Changing data structure forced command termination"

(OP)
Hello,
I was informed by IBM community group that this is a known bug for informix version 11.40 FC9.
I am posting this here for anyone who might experience the same issue.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close