×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

One-way Audio on BCM50 with Flowroute
2

One-way Audio on BCM50 with Flowroute

One-way Audio on BCM50 with Flowroute

(OP)
I have used Flowroute SIP trunks on my BCM50 R6 for about 7 years with minimal issues. About 2 weeks ago I started having issues with one-way audio on incoming calls. The caller could hear me, but I couldn't hear them. Outgoing calls work fine.

I am using the same settings on the BCM50 that I have used for years, but Flowroute now tells me my system is sending the private LAN IP address instead of the public IP address. Temporarily placing the BCM50 in the DMZ of my router did not change anything.

I've tried enabling NAT compensation and Media Relay in advanced settings, but Flowroute says the system is still sending the LAN IP address. I've also enabled the STUN server even though my public IP never changes. I've also swapped in a new hard drive to no avail. Still the same problem.

Any suggestions?

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: One-way Audio on BCM50 with Flowroute

I just looked at your screen shots from another post...the one where you went through LXLS's screenshots, lol.

You are missing a Port number in Registrar, is this by design?
I am thinking you should at least have port 5060 or 5160 in the Registrar port field?

Flowroute appears to be big on port forwarding after looking here too.

As for the issue...
I think in my past testing, if you manually provision the Public IP in Subsystem then Local NAT Compensation should be set to disabled.
If you use STUN then Local NAT Compensation should be enabled.
Either way that Discovered Public IP Address needs to populate.

I will bump accumat's thread and see if he can try some of the same.








=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: One-way Audio on BCM50 with Flowroute

DNS!
?

It appears Tek-Tips search has a better memory than mine.
I appear to have had the same issue with one of my clients in the states.

Did you change the DNS on the BCM or Router?



=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: One-way Audio on BCM50 with Flowroute

(OP)
Curly, I've tried all your suggestions. I have DNS settings matching the router. I've turned NAT compensation on and off. I've enabled STUN. I also restarted the feps service after each change. I even put the BCM50 in the DMZ of my router. Nothing I do makes any difference. One-way audio on incoming calls.

I continue to get one-way audio on incoming calls, while Flowroute tells me the BCM is sending the local LAN address instead of the public IP address. My original settings had been working for about 7 years when they suddenly started failing 2 weeks ago. I replaced the hard drive and restored a recent backup to no avail. Firmware in my router hasn't changed in months.

My last desperate attempt will be to install another BCM50 and manually key in all the IP and SIP settings. If that fails then I'm done with Flowroute.

Yesterday I fired up my Pi3 Asterisk server and manually keyed in the SIP settings. Calls work both ways with great voice quality. Unfortunately all incoming calls drop after exactly 32 seconds and every suggestion I've tried from the Asterisk forums makes no difference. Outgoing is fine with no drops.

I have to believe Flowroute has changed something in their setup as two different systems have issues with incoming calls.

I'll keep you posted on whether another BCM50 fixes the problem. Thanks for diving in on this thread.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: One-way Audio on BCM50 with Flowroute

(OP)
Well, spent most of the morning messing with another BCM50 with a fresh hard drive. I manually input all the settings and voila! It does the same thing as my existing system, one-way audio on incoming calls.

Looks like I'm on the hunt for a new SIP provider as Flowroute's tech support has been no help in this case.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: One-way Audio on BCM50 with Flowroute

I was thinking it's time for wireshark maybe.




=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: One-way Audio on BCM50 with Flowroute

exsmogger,

I got your message in the other thread, I'll post the response here though.

My router is a Dell Server running VMWare ESXi 7, a VM running pfSense is acting as the router for this network, with one port mapped directly to a physical port on the host, connected to the ONT at the side of the house.

The BCM was configured when I was just getting started with telecom, which is not where my background is, and as such, probably not configured 100% correctly. I believe it was you that sent me some screenshots last time I was having an issue with audio dropping after an incoming call was placed on hold. That issue I never was able to resolve, similar to the problem you're having now, FR told me that when the system picks up the call on hold, it sends the internal address of the BCM; when I get around to it, I'm going to try a fresh image and reconfigure knowing what I know now.

I've sent an archive of the screenshots to your eMail.

RE: One-way Audio on BCM50 with Flowroute

"I think in my past testing, if you manually provision the Public IP in Subsystem then Local NAT Compensation should be set to disabled.
If you use STUN then Local NAT Compensation should be enabled."


Sorry, ignore that comment as it had only applied when my other configurations were apparently wrong.


My recent one-way audio issue (cannot hear inbound caller) was because I had changed my port numbers in Basic/ Proxy and Registrar to 42872 but eventually found out it was because they did not match SIP/Global Settings Call Signaling port which was 5060.
Not sure why there is a global setting that prevents other ports from being used.

I have taken screenshots of my setup and PDF'd them, download link is below.
They are settings for Voip.MS, the main account is not registered, only sub accounts are.





=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: One-way Audio on BCM50 with Flowroute

(OP)
Making some progress at last. It looks like the Xfinity gateway is partially to blame. My Netgear router was in the DMZ of the gateway. I found out how to disable the firewall in the gateway, and then took my router out of the DMZ. I also disabled an Xfinity "feature" called Advanced Security which flags what it deems suspicious traffic and blocks it. I made a test call from my cell phone to the BCM50 and I now had 2-way audio.

Unfortunately it didn't work on every incoming call, so I temporarily port forwarded 5060 to the BCM50. Now voice traffic seemed to work more consistently. My router doesn't have a setting to filter traffic to only my SIP provider, so I deleted the port forward so as not to tempt hackers with an open port 5060.

I just ordered an Asus router that gberger was kind enough to recommend in a thread about 6 months ago (https://www.tek-tips.com/viewthread.cfm?qid=181252...). I intend to put only my BCM50 behind the Asus and port forward 5060 and the RTP ports 28000-28255. I did a tcpdump capture while logged in to SSH and my phone consistently used port 28002. So it appears all VoIP audio traffic uses the RTP over UDP ports specified in "Port Ranges" in Element Manager.

A well deserved star for LXLS and curlycord for sending me their screenshots. LXLS, I decided to go the quick route rather than build a pfSense router as you suggested. I just don't have the time for another project right now.

Will update after I install the new router.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: One-way Audio on BCM50 with Flowroute

(OP)
Looks like I finally stumbled upon a fix for my audio problems. I used a technique that teltech317 posted in thread https://www.tek-tips.com/viewthread.cfm?qid=178013....

I made the following changes to my setup:

In Public/Accounts/Advanced it now looks like this.



In Global Settings it now looks like this.



In Public/Accounts/User Accounts it now looks like this.



Filling in the Contact Override with one of my incoming DID numbers seems to be the key to finally making 2-way audio work. When I changed the entry to my account ID or deleted it altogether, incoming calls went back to one-way audio.

Since I have 2 DIDs I will need to setup a separate account with Flowroute for my second DID. For now I programmed the route for my second number on the Flowroute portal to ring my cell phone.

I gave a well earned star to teltech317 on the original thread. Many thanks to all who contributed in this thread.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: One-way Audio on BCM50 with Flowroute

Nice

FYI to some and with different cases or carriers:
Aside from now knowing Contact Override works too in this particular case, if does not work:

If you use OLI then your pushing out the same number no matter what account you use which could cause issues.
It is best to instead use PAI CLID Override, and may include you having your phone number (or user name) in the CLID Override.






=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: One-way Audio on BCM50 with Flowroute

(OP)
I've been playing with the different settings for message handling as this seems to alter the SIP headers being sent from the BCM. I cleared the contact override and filled in the other entries like so:



I made test calls from my cell phone, and my dad's landline and still had 2-way audio. I will leave it like it is for now and see what happens.

I've been scouring the BCM50 IP Telephony manual trying to glean what all of these settings actually do. Trial and error is usually the long path to a solution.

Thanks.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: One-way Audio on BCM50 with Flowroute

Yes, I spent hours figuring this combo out.
My setup per the above guide I included shows the same as your new one above except I left Display name Override blank.



=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: One-way Audio on BCM50 with Flowroute

(OP)
After working for the most part all evening on June 29, calls went back to one-way audio the next morning. I will try the new router when it gets here tomorrow, but that's my last gasp. I've already spent too much time fighting this problem after 7 years of 90%+ trouble free service.

In the meantime I have a Raspberry Pi3 loaded with Asterisk that I installed today. I have my Flowroute SIP trunks working on it with good audio both ways. I just need to figure out the quirks in its programming. I have both Nortel unistim and SIP phones working on the Asterisk. Really amazing for something the size of a deck of cards.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: One-way Audio on BCM50 with Flowroute

(OP)
Well, I had to retire my BCM50 and switched to a Raspberry Pi3 with Asterisk/FreePBX. Nothing I tried would make the BCM50 send the public IP address in the SIP headers. I even tried a trial SIP trunk from SIP.US and their support said my BCM50 was registering with the private IP address. I made the switch to the Asterisk over the weekend. My SIP trunks are working well, and the Asterisk is sending the public IP address as it should.

I have a couple of Nortel 1230 IP phones with unistim firmware working on the Asterisk, as well as the Zoiper app on my smartphone. This is certainly an improvement from my early days at Pacific Telephone covering a wall with equipment and wiring panels to make a few 1A2 phones work. lol

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close