×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

BCM50e Caller ID issue.

BCM50e Caller ID issue.

BCM50e Caller ID issue.

(OP)
Good afternoon everyone,

I just brought up a BCM50e with the latest Rls 6. Everything seems to work as expected, except for Caller ID. I have one trunk and one 7324 telset set up. I can manually switch the trunk connection between 2 trunks which I'm doing for testing.

The issue I'm having is that on either trunk, I'm getting CV in the 7324 display after the second ring. Both of my trunks are Magicjack lines and both have been tested with and without the 100k Caller ID fix. Both trunks were tested on a Partner ACS and pass Caller ID correctly to an Avaya 34D.

The Caller ID is displayed correctly in the BCM Monitor.

Would anyone happen to have some insight into what might be going on with this?

Thank you!

Jim

RE: BCM50e Caller ID issue.

I've had a BCM50 in my house for about 10 years. Never had trouble with caller ID on my SIP trunks. But today I got an unsolicited call and the caller ID name showed "CV" like you are getting. All other calls I had today displayed normally. I looked at my CDR log and it shows the name for that call as "[V] IDEAL." Very weird.

It's the first time I've ever seen "CV" displayed. Hope someone on the forum has an answer. Tried Googling with no results.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: BCM50e Caller ID issue.

(OP)

Good evening,

In an attempt to narrow down my Caller ID issue on the BCM50e, I've connected an Analog Set w/CID (on 233) to the BCM. I have assigned the set to trunk (061) and selected Prime Line as Line:061.

I can receive calls on the Analog Set and after the second ring, it does display Caller ID.

So, CV displayed on the 7324 and correct CID on the analog set.

Just an FYI.

Thanks.

Jim

RE: BCM50e Caller ID issue.

(OP)

Although we have Comcast, they're only providing 1gps internet and don't provide any phone services for us.

Thank you for the response.

Jim

RE: BCM50e Caller ID issue.

Just a thought...
[V] - maybe the M7324 digital set (possibly other Nortel models) cannot decipher brackets and/or confused and spits out CV?

Exsmogger what set model was yours?



=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: BCM50e Caller ID issue.

Mine is a 1230 IP phone with the latest firmware. I just checked one of my T7316's and the caller ID log shows "[V". Looks like the 1230 interprets the first bracket as a "C", whereas the T7316 passes the first bracket, but can't interpret the second bracket.

This indicates the phone firmware can't correctly interpret characters other than numbers and letters. The only fix would seem to be getting the sending party to clean up their act on sending the caller ID name. There's obviously no chance of updating the phone firmware.

Edit to add: the caller ID number comes through fine when I toggle. My phones are set for display name first.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: BCM50e Caller ID issue.

exsmogger

I have the Verified Caller ID problem as well, and am also on a BCM 50 R6 with Flowroute Trunks.

As I've learned, Verified Caller ID is part of STIR/SHAKEN and was a regulatory mandate. When I approached Flowroute about this issue, they told me they could not - and would not turn off Verified CID. Myself and a couple other 50's under my care are all exhibiting the exact same symptoms you report. It doesn't seem to matter what station is being used, It's a problem on 1140e, 1230, T7316e, M7324. When "[V" appears on my system, I know it's usually a legit call, but its kinda a bummer that FR won't work with me in any way. The Norstar's under my care exhibit the exact same symptoms. BCM Monitor doesn't appear to have an issue decoding the CID. :(

RE: BCM50e Caller ID issue.

Right. My call detail recording logs show the correct name, but the sets get confused by the format. Flowroute has been very good at working with me over the years to resolve SIP issues. That's disappointing that they won't strip the [V] from the headers.

The only fix I can think of is to enter the incoming number into the system speed dial list and enter a friendly name. The next time the number calls in the system will display the friendly name instead of the registered caller ID name. However, it's a shame to eat up system speed dial entries that way.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: BCM50e Caller ID issue.

LXLS, I got the same response from Flowroute about the verified caller "feature."

Here's a funny aside. I was messing with my Raspberry Pi3 Asterisk server yesterday and programmed my Flowroute SIP trunks into the configuration. Calls work both ways with good voice quality, but all incoming calls drop after exactly 32 seconds. Never did figure out a fix.

I was making test calls from my cell phone to the Asterisk. I have an old unistim 2002 IP phone connected to the Asterisk. Lo and behold the caller ID displayed on this ancient IP phone showed "470281xxxx [V]"
So an old 2002 can correctly display the [V], but every other Nortel digital or IP phone I've tried mangles the caller ID. You just have to shake your head and laugh.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952
https://brian-cox.square.site/

RE: BCM50e Caller ID issue.

Responded in the separate thread exsmogger created for this issue.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close