×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

1140e firmware upgrade

1140e firmware upgrade

1140e firmware upgrade

(OP)
Greetings!

I was looking for a solution to upgrade the firmware on a pair of 1140e beyond 0625C98, and found a closed thread that ended with the question: did anyone try to go to SIP and back to upgrade the phone?

Originally I tried loading C99, C9A, C9B, C9C, C9D, in succession got: [FW] Auth. Failed. Then downgraded it to 0625C7J, and tried to load C9D, C9C, C9B, C9A, C99, all stopped with [FW] Auth. Failed again. I didn't test downgrading farther than that. From C7J, I tried going to C9D - C99, all failed, but C98 did load.

At C98, tried to load SIP, and got [FW] Auth. Failed on versions 04.04.42.00 down through 04.04.10.00, and 04.01.15.00.

Finally got SIP to load at version 04.00.04.00. Once it rebooted, I set the cfg file for the Unistim bin 0625C9D, and it loaded straight up!

The first 1140 I've tried it on was: NTYS05AEE6.

David


Verulam Telephone:
Communicating is our Pleasure!

Serving Northern Ontario

RE: 1140e firmware upgrade

Hey dude

What are you trying to actually do? convert to SIP or just upgrade the UNIStim?

The last supported firmware released for BCM was 62xC96 (UNIStim 5.5.8), any firmware after that is no longer listed as being supported on BCM.
The above mentioned firmware is for sets 11xx, 12xx and 2007 and on a BCM50/450 R6.

There are some rare instances where you do need to back up an/or not jump to far.

I attached here is a PDF that I just did a few days ago.





=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: 1140e firmware upgrade

(OP)
Hey Curly, yes, should have pinpointed the problem properly: "trying to upgrade to latest UNISTIM release and it won't load? Here's a workaround..."

LOL

I tried to upgrade firmware on some 1140s to the latest UNIStim release, and they refused to load it... with [FW] Auth. Failed (Starting with units that had C96, C97 and C98 in them)

After jumping through the hoops, I thought I would share what I found.

The upgraded firmware (0625C9D) works fine on BCM400 (3.7,) and some are working well as UNIStim extensions on an Asterisk system. Although asterisk configuration is a bitch, no issues have been noted since upgrade...

David

Verulam Telephone:
Communicating is our Pleasure!

Serving Northern Ontario

RE: 1140e firmware upgrade

Thanks for the update.

"FW Authentication Failure" usually means it's already at that firmware or it does not understand the firmware you want.


"There are some rare instances where you do need to back up an/or not jump to far"

Coincidently, I had to do just that in a very strange case last week....

Ayaya IP 1140e NTYS05 YEAR 2014 - FW UNIStim 0625C94

No audio when connected via Remote Worker to a particular BCM50 R6 - patches not the latest
This same set worked fine when connected to several other BCM50 sites, also R6's but with latest patches
Other sets worked fine at the suspected problem BCM

My own hoops over the course of about 12 hours...

-Matching settings on a 2nd IP1140 NTYS05 that works
-Changing settings even if matched
-Factory Resetting the phone via RENEW
-Changing to many different UNIStim firmware's
-Installed latest patches on the BCM
-Scouring the internet
-Changing to SIP 4.0 then back to UNIStim 0625C94
-At the 9th hour mark: Checking the Driveway to see if any cars parked on it & looking for the Buford Pusser stick.
-Decided to swap out this set with my own NTYS05 set that works and be done with this
-Went into Auto settings and un-checked stuff I did not want the client to mess with...Vlan, XAS mode and 2 or 3 more items and rebooted.
-NO AUDIO on that set now! looking for the damn chainsaw!!
-Again matching settings and trying to remember what I disallowed, reversed what I could, no dice
-Back to scouring the internet
-Changing original problem set back to SIP again but to 2.0 this time.
-All kinds of errors trying to get it back to UNIStim 0625C94, No Authentication, FW Failed and more.
-At the 11th hour mark: looking for the keys for my truck and checking the tires.
-Back to scouring the internet, found something:
need to go from SIPv2 to SIPv3 then to SIPv4 or UNIStim
-Tried upgrading SIPv2 to SIPv3 then to UNIStim 0625C94, no dice "then to SIPv4 or UNIStim" is not so true!"
-Tried upgrading SIPv3 to SIPv4 then to UNIStim 0625C94, finally it took, finally audio issue fixed!
-Did the same for my own set, all works now and afraid to touch settings!

So my actual fix choosing random versions within the 3 releases was:

Convert UNIStim to SIPv2: SIP1140e02.02.16
Upgrade SIPv2 to SIPv3: SIP1140e02.02.16 to SIP1140e03.00.65.00
Upgrade SIPv3 to SIPv4: SIP1140e03.00.65.00 to SIP1140e04.04.26.00
Convert SIPv4 to UNIStim: SIP1140e04.04.26.00 to UNIStim 0625C94[/b]





=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: 1140e firmware upgrade

My IP 1140e phone is on the lastest firmware release of 1625C9A.bin on a BCM 50 at release 6.0

I got a 1230 up to 162AC9A. Here's one method.

1 - Used the TFTP server to force it back to 062AC8Y
2 - Upgraded to 062AC9A from the BCM50. That worked fine.
3 - Upgraded to 062AC9B from the BCM50. The phone rebooted one time and then upgraded fine.
4 - Tried to force upgrade from the BCM50, but nothing happened.
5 - Force upgraded to 162AC9A from the TFTP server. That worked fine and the phone is operational.

What I’ve done is to “play” with my 1140e IP phone and I had to revert it back to 0625C8Y.bin, although I’m guessing that it will probably work with other software releases etc. I did this via a TFTP server using the 1140e.cfg file with..

[FW]
DOWNLOAD_MODE FORCED
VERSION 0625C8Y
PROTOCOL TFTP
FILENAME 0625C8Y.bin
SERVER_IP 192.168.1.21

Please refer to the attached giude for more details.

Firebird Scrambler

Nortel & Avaya Meridian 1 / Succession & BCM / Norstar Programmer

Website = http://somertel.net
linkedin

RE: 1140e firmware upgrade

I had the same experience as Firebird. In my case it was a 1230 IP phone.

The phone was originally at 062AC97, but it would fail when I tried to upgrade to 062AC9A from my BCM50. Here's the steps I took:

1 - Forced back to 062AC8Y from the TFTP server.
2 - Upgraded to 062AC9A from the BCM50. Worked OK.
3 - Upgraded to 062AC9B from the BCM50. Rebooted once, then upgraded OK.
4 - Tried to force upgrade to 162AC9A from the BCM50. Nothing happened.
5 - Upgraded to 162AC9A from the TFTP server. Worked OK.

This set is now working fine with the latest release firmware on my BCM50 R6.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close