×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

MATWorx 13 on Windows 11

MATWorx 13 on Windows 11

MATWorx 13 on Windows 11

(OP)
trying to install MATWorx v13 on Windows 11 and getting the following error message. seemed to work fine on WIN10. cant run it as administrator as it hasn't loaded yet, tried a few different compatibility options but still get the same error message


"failed to get application Information value"



RE: MATWorx 13 on Windows 11

The program was never updated to work on WIN 10, however it does work in XP mode. WIN 11, probably will not work.

RE: MATWorx 13 on Windows 11

I could never get it to install on Windows 10. I have a virtual instance of Windows XP running on my Windows 10 laptop. Using Virtualbox. I use this for all of my legacy systems that we don't see very often.

RE: MATWorx 13 on Windows 11

I got it to work by loading it, then right click on it and run it in XP mode.

RE: MATWorx 13 on Windows 11

(OP)
so that was definately on WIN11??

I have had it working on WIN10 as well

RE: MATWorx 13 on Windows 11

My previous post may have been misleading. I got it working on WIN 10. I have no PC's with WIN 11 and am not surprised it doesn't work. WIN 11 is new and untested on many applications.

RE: MATWorx 13 on Windows 11

I just went though my own struggles getting MATWorX 13 re-installed on a Windows 10 laptop, but the issue looks the same as you're having on Windows 11. I was getting the "Failed to get application information value" error as soon as I would click through the first few prompts from the Installer. Yes, I could have just bailed and used an old laptop or a virtual machine, but that's no fun. After digging through the TrustedInstaller code, the fix for that particular issue was to add two Registry strings that the installer was looking for (which were missing on my machine):

\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion
Using regedit, I added String Values in both of those Keys with Value Name "RegisteredOrganization" and kept Value Data empty.

Once I did that, the program installed normally. But I still had a few issues: 1) the program would throw an "Unexpected error; quitting" alert when I tried to open it, 2) it would give a "System Fatal Notice" that "Object variable or With block variable not set [91]", and/or 3) it would give a notice saying COMCTL32.OCX or COMDLG32.OCX were missing or not registered correctly. The fixes for those those issues were:

1) As belvedere mentioned, always run the program(s) in Compatibility Mode for Windows XP SP2, and As Administrator if needed. That fixed the first two problems for me.
2) I copied the COMCTL32.OCX and COMDLG32.OCX files from a working machine and dropped them into C:\Windows\SysWOW64 (you could make a copy of or rename the files if they exist already). I then re-registered the files by running the following in an elevated Command Prompt:

C:\Windows\SysWOW64\regsvr32 C:\Windows\SysWOW64\comctl32.ocx
C:\Windows\SysWOW64\regsvr32 C:\Windows\SysWOW64\comdlg32.ocx

After that, the program opened and functioned normally for me (so far). I can't guarantee this will all work on Windows 11, but hope it helps! Also let me know if you want/need a copy of those two Visual Basic files.

RE: MATWorx 13 on Windows 11

(OP)
abayham, winner winner

made the changes in regedit as described and the program loaded and seems to run withoiut issue - after setting it for compatability mode

thnaks again, saves me carrying two laptops when I look after 4 x IPS PABXs on a preserved railway telephone system.

i havent had to load the comctl32.ocx or comdlg32.ocx yet..........

mainthing is soltaire and freecell still work on WIN!!

thanks again for the assistance, once again tek-tips is a great site

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close