×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

IX workplace enterprise directory

IX workplace enterprise directory

IX workplace enterprise directory

(OP)
We used to have the directory listed in one-x and the old avaya communicator but cannot get this to work with ix workplace.

I have an application server running on the UC module in ip500v2.
I have a trusted certificate on the IP Office and installed the same certificate on the application server.
I can place calls using IX workplace but no way to list the IP Office directory.

Does anybody knows what should be the settings to use in the IX workplace Enterprise directory as per attached screenshot?
Do they have to be IP Office ip address or App Server IP Address? TLS? and what port is used for the directory?

RE: IX workplace enterprise directory

Avaya Workplace does not use the One-X Portal for its directory, it gets it from the IPO using http/https ports 80/443.

The Enterprise Directory service is not needed, so turn it off.

“Some humans would do anything to see if it was possible to do it.
If you put a large switch in some cave somewhere, with a sign on it saying 'End-of-the-World Switch. PLEASE DO NOT TOUCH'.
The paint wouldn't even have time to dry.”

Terry Pratchet

RE: IX workplace enterprise directory

(OP)
Thanks for the tip.
I removed that but nothing loads from the IP Office directory.
When I type some initials in the contact search nothing shows up and "Enterprise Directory not available" is shown.
I also have a yellow !mark "Contact Service problem..your contacts may not be up to date"

I am not behind any firewall..I am running the app on the same network of the IP Office to test it out first.

RE: IX workplace enterprise directory

If I recall correctly, the directory uses HTTPS, so most likely port or certificate issue.

Stuck in a never ending cycle of file copying.

RE: IX workplace enterprise directory

Try searching for a known contact name. If it comes up, you have to save it for it to always be displayed. You may also add names to Favorites by clicking the star icon.

RE: IX workplace enterprise directory

It seems you have to type in the first few letters to bring up a result. This is from the IPO directory and Enterprise directory off.



This may be to stop IX Workplace having to store the whole directory.



Looking at the settings enterprise directory needs an LDAP server.

RE: IX workplace enterprise directory

(OP)
when I typed:
https://ipoffice address/system/user/scn_user_list

I managed to get the directory in xml format in the browser. Therefore from IP office all is good.
I am using a trusted certificate but cannot get the directory to show in the App. Is this issue certificate related?

RE: IX workplace enterprise directory

Are you using TCP or TLS? If I remember right you have to be using TLS with a valid certificate for the directory to work.

The truth is just an excuse for lack of imagination.

RE: IX workplace enterprise directory

(OP)
I am using TLS. The certificate is valid..so really strange.

RE: IX workplace enterprise directory

(OP)
So managed to get this to work and to get it to work I have to forward port 443 on the firewall to the IP Office.
My question is...is it secure enough?
if someone now uses a browser and types in the URL of our public ip will get access to attempt a login to the web management interface of IP Office.

RE: IX workplace enterprise directory

(OP)
I would like to give a tip to those (like me) who wasted precious time trying to connect IP Office directory in IX workplace.

The only method that works is to get the IX workplace application (both on smartphones and on Windows) to retrieve automatic settings using URL (example: https://certificatenameonipoffice.domain.com/46xxs...)

Certificate must be trusted on ip office. To verify this..use your browser and goto https://certificatenameonipoffice.domain.com/46xxs.... Make sure that the browser should not give you any certificate warnings to the page opened.

Forwarding SIP socket being used towards IP Office (ex: 5061 - depending on your system>lan>voip>SIP registrar setting (together with the UDP range of ports)
Forward port 443 towards ip office.



Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close